summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/linux-headers/linux-headers-2.4.22.ebuild')
-rw-r--r--sys-kernel/linux-headers/linux-headers-2.4.22.ebuild18
1 files changed, 14 insertions, 4 deletions
diff --git a/sys-kernel/linux-headers/linux-headers-2.4.22.ebuild b/sys-kernel/linux-headers/linux-headers-2.4.22.ebuild
index 436da6dd83e7..1a7456e563a6 100644
--- a/sys-kernel/linux-headers/linux-headers-2.4.22.ebuild
+++ b/sys-kernel/linux-headers/linux-headers-2.4.22.ebuild
@@ -1,13 +1,14 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.4.22.ebuild,v 1.5 2003/10/30 23:17:54 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/linux-headers/linux-headers-2.4.22.ebuild,v 1.6 2003/11/16 18:26:58 kumba Exp $
-ETYPE="headers"
-inherit kernel
OKV=${PV/_/-}
+KV="${OKV}"
S=${WORKDIR}/linux-${OKV}
-EXTRAVERSION=""
+EXTRAVERSION=" "
+ETYPE="headers"
+inherit kernel
# What's in this kernel?
@@ -52,6 +53,15 @@ src_unpack() {
epatch ${FILESDIR}/bigendian-byteorder-fix.patch
fi
+
+ # This patch fixes an issue involving the use of gcc's -ansi flag and the __u64 datatype.
+ # It only patches asm-i386, so we only apply it if x86. Unknown if this is needed for other archs.
+ # Closes Bug #32246
+ if [ -n "`use x86`" ]; then
+ epatch ${FILESDIR}/${PN}-strict-ansi-fix.patch
+ fi
+
+
# Do Stuff
kernel_universal_unpack
}