summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-kernel/grsec-sources/grsec-sources-2.4.23.2.0_rc4.ebuild')
-rw-r--r--sys-kernel/grsec-sources/grsec-sources-2.4.23.2.0_rc4.ebuild13
1 files changed, 6 insertions, 7 deletions
diff --git a/sys-kernel/grsec-sources/grsec-sources-2.4.23.2.0_rc4.ebuild b/sys-kernel/grsec-sources/grsec-sources-2.4.23.2.0_rc4.ebuild
index 957c4e60e296..26e2d5730609 100644
--- a/sys-kernel/grsec-sources/grsec-sources-2.4.23.2.0_rc4.ebuild
+++ b/sys-kernel/grsec-sources/grsec-sources-2.4.23.2.0_rc4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/grsec-sources/grsec-sources-2.4.23.2.0_rc4.ebuild,v 1.1 2004/01/05 22:10:53 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/grsec-sources/grsec-sources-2.4.23.2.0_rc4.ebuild,v 1.2 2004/01/05 23:06:16 plasmaroo Exp $
# Documentation on the patch contained in this kernel will be installed someday
@@ -29,6 +29,7 @@ S=${WORKDIR}/linux-${KV}
###################
src_unpack() {
+
unpack linux-${OKV}.tar.bz2 || die "Unable to unpack the kernel"
mv linux-${OKV} linux-${KV} || die "Unable to move the kernel"
cd linux-${KV} || die "Unable to cd into the kernel source tree"
@@ -40,15 +41,13 @@ src_unpack() {
die "Unable to the kernel patch"
fi
- epatch ${FILESDIR}/do_brk_fix.patch || die "failed to patch for do_brk vuln"
+ epatch ${FILESDIR}/do_brk_fix.patch || die "Failed to patch for do_brk() vulnerability!"
+ epatch ${FILESDIR}/${PN}-${OKV}.CAN-2003-0985.patch || die "Failed to patch mremap() vulnerability!"
+ epatch ${FILESDIR}/${PN}-${OKV}.rtc_fix.patch || die "Failed to patch RTC vulnerabilities!"
mkdir -p docs
touch docs/patches.txt
kernel_universal_unpack
- # kernel_src_unpack
-}
-#src_install() {
-# kernel_src_install
-#}
+}