summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-freebsd/freebsd-usbin/files/freebsd-usbin-flex.patch')
-rw-r--r--sys-freebsd/freebsd-usbin/files/freebsd-usbin-flex.patch155
1 files changed, 155 insertions, 0 deletions
diff --git a/sys-freebsd/freebsd-usbin/files/freebsd-usbin-flex.patch b/sys-freebsd/freebsd-usbin/files/freebsd-usbin-flex.patch
new file mode 100644
index 000000000000..27327fdff773
--- /dev/null
+++ b/sys-freebsd/freebsd-usbin/files/freebsd-usbin-flex.patch
@@ -0,0 +1,155 @@
+diff -ur usr.sbin/apmd/Makefile usr.sbin-flex/apmd/Makefile
+--- usr.sbin/apmd/Makefile 2004-01-21 13:38:17 +0000
++++ usr.sbin-flex/apmd/Makefile 2005-05-05 18:05:56 +0000
+@@ -6,7 +6,7 @@
+ SRCS= apmd.c apmdlex.l apmdparse.y y.tab.h
+
+ DPADD= ${LIBL}
+-LDADD= -ll
++LDADD= -lfl
+
+ YFLAGS+=-v
+ CFLAGS+=-I. -I${.CURDIR} #-DYY_STACK_USED
+diff -ur usr.sbin/config/Makefile usr.sbin-flex/config/Makefile
+--- usr.sbin/config/Makefile 2004-05-11 15:42:44 +0000
++++ usr.sbin-flex/config/Makefile 2005-05-05 18:06:13 +0000
+@@ -10,7 +10,7 @@
+ CFLAGS+= -I. -I${.CURDIR}
+
+ DPADD= ${LIBL}
+-LDADD= -ll
++LDADD= -lfl
+
+ mkmakefile.o: configvers.h
+
+diff -ur usr.sbin/crunch/examples/filesystem.conf usr.sbin-flex/crunch/examples/filesystem.conf
+--- usr.sbin/crunch/examples/filesystem.conf 1999-08-28 01:15:57 +0000
++++ usr.sbin-flex/crunch/examples/filesystem.conf 2005-05-05 18:06:29 +0000
+@@ -28,4 +28,4 @@
+ # /usr/sbin
+ progs bad144
+
+-libs -ll -ledit -ltermcap -lutil -lscrypt
++libs -lfl -ledit -ltermcap -lutil -lscrypt
+diff -ur usr.sbin/crunch/examples/fixit.conf usr.sbin-flex/crunch/examples/fixit.conf
+--- usr.sbin/crunch/examples/fixit.conf 1994-12-31 05:36:40 +0000
++++ usr.sbin-flex/crunch/examples/fixit.conf 2005-05-05 18:06:43 +0000
+@@ -41,5 +41,5 @@
+
+ # finally, we specify the libraries to link in with our binary
+
+-libs -lcrypt -ltelnet -lutil -ll
++libs -lcrypt -ltelnet -lutil -lfl
+ libs -lcurses -ltermcap -ledit -lkvm
+diff -ur usr.sbin/crunch/examples/kcopy.conf usr.sbin-flex/crunch/examples/kcopy.conf
+--- usr.sbin/crunch/examples/kcopy.conf 1999-08-28 01:15:57 +0000
++++ usr.sbin-flex/crunch/examples/kcopy.conf 2005-05-05 18:06:53 +0000
+@@ -18,4 +18,4 @@
+ ln reboot fastboot
+ ln reboot fasthalt
+
+-libs -ll -ledit -ltermcap -lcompat -lutil -lscrypt
++libs -lfl -ledit -ltermcap -lcompat -lutil -lscrypt
+diff -ur usr.sbin/crunch/examples/really-big.conf usr.sbin-flex/crunch/examples/really-big.conf
+--- usr.sbin/crunch/examples/really-big.conf 2001-06-01 11:25:40 +0000
++++ usr.sbin-flex/crunch/examples/really-big.conf 2005-05-05 18:07:06 +0000
+@@ -155,4 +155,4 @@
+ ln gzip gzcat
+
+ libs -ledit -lgnumalloc -lc -lcrypt -ltermcap -lcurses -ltelnet -lutil -lkvm
+-libs -ll -ly -lm -lresolv -lrpcsvc -lcompat
++libs -lfl -ly -lm -lresolv -lrpcsvc -lcompat
+diff -ur usr.sbin/ipsend/Makefile usr.sbin-flex/ipsend/Makefile
+--- usr.sbin/ipsend/Makefile 2003-06-06 11:30:50 +0000
++++ usr.sbin-flex/ipsend/Makefile 2005-05-05 18:07:16 +0000
+@@ -18,6 +18,6 @@
+ -I${.CURDIR}/../../contrib/ipfilter
+
+ DPADD= ${LIBL}
+-LDADD= -ll
++LDADD= -lfl
+
+ .include <bsd.prog.mk>
+diff -ur usr.sbin/kbdcontrol/Makefile usr.sbin-flex/kbdcontrol/Makefile
+--- usr.sbin/kbdcontrol/Makefile 2003-04-04 17:49:14 +0000
++++ usr.sbin-flex/kbdcontrol/Makefile 2005-05-05 18:07:41 +0000
+@@ -9,6 +9,6 @@
+ CFLAGS+= -I${.CURDIR}
+
+ DPADD= ${LIBL}
+-LDADD= -ll
++LDADD= -lfl
+
+ .include <bsd.prog.mk>
+diff -ur usr.sbin/ndiscvt/Makefile usr.sbin-flex/ndiscvt/Makefile
+--- usr.sbin/ndiscvt/Makefile 2004-02-23 20:21:21 +0000
++++ usr.sbin-flex/ndiscvt/Makefile 2005-05-05 18:07:53 +0000
+@@ -12,7 +12,7 @@
+ WARNS?= 4
+
+ DPADD= ${LIBL}
+-LDADD= -ll
++LDADD= -lfl
+
+ YFLAGS+=-v
+
+diff -ur usr.sbin/pcvt/kbdio/Makefile usr.sbin-flex/pcvt/kbdio/Makefile
+--- usr.sbin/pcvt/kbdio/Makefile 2005-02-13 07:23:45 +0000
++++ usr.sbin-flex/pcvt/kbdio/Makefile 2005-05-05 18:08:19 +0000
+@@ -13,7 +13,7 @@
+ LFLAGS+= -I
+
+ DPADD= ${LIBM} ${LIBY} ${LIBL}
+-LDADD= -lm -ly -ll
++LDADD= -lm -ly -lfl
+
+ CLEANFILES+= y.output # comment file from bison
+
+diff -ur usr.sbin/pcvt/vgaio/Makefile usr.sbin-flex/pcvt/vgaio/Makefile
+--- usr.sbin/pcvt/vgaio/Makefile 2001-07-20 06:20:09 +0000
++++ usr.sbin-flex/pcvt/vgaio/Makefile 2005-05-05 18:08:08 +0000
+@@ -14,7 +14,7 @@
+ LFLAGS+= -I
+
+ DPADD= ${LIBM} ${LIBY} ${LIBL}
+-LDADD= -lm -ly -ll
++LDADD= -lm -ly -lfl
+
+ CLEANFILES+= y.output # comment file from bison
+
+diff -ur usr.sbin/rrenumd/Makefile usr.sbin-flex/rrenumd/Makefile
+--- usr.sbin/rrenumd/Makefile 2004-06-21 16:10:00 +0000
++++ usr.sbin-flex/rrenumd/Makefile 2005-05-05 18:08:30 +0000
+@@ -21,7 +21,7 @@
+ CFLAGS+= -DINET6 -DIPSEC -I. -I${.CURDIR}
+ YFLAGS= -d
+
+-LDADD= -lipsec -ll -ly
++LDADD= -lipsec -lfl -ly
+ DPADD= ${LIBIPSEC} ${LIBL} ${LIBY}
+
+ CLEANFILES= y.tab.h
+diff -ur usr.sbin/setkey/Makefile usr.sbin-flex/setkey/Makefile
+--- usr.sbin/setkey/Makefile 2003-11-05 09:47:54 +0000
++++ usr.sbin-flex/setkey/Makefile 2005-05-05 18:08:48 +0000
+@@ -35,7 +35,7 @@
+ YFLAGS= -d
+
+ DPADD= ${LIBL} ${LIBY}
+-LDADD= -ll -ly
++LDADD= -lfl -ly
+
+ CLEANFILES= y.tab.c y.tab.h key_test.o keytest
+
+diff -ur usr.sbin/tcpdump/tcpdump/Makefile usr.sbin-flex/tcpdump/tcpdump/Makefile
+--- usr.sbin/tcpdump/tcpdump/Makefile 2004-08-06 07:27:08 +0000
++++ usr.sbin-flex/tcpdump/tcpdump/Makefile 2005-05-05 18:08:58 +0000
+@@ -41,7 +41,7 @@
+ .endif
+
+ DPADD= ${LIBL} ${LIBPCAP}
+-LDADD= -ll -lpcap
++LDADD= -lfl -lpcap
+ .if !defined(NOCRYPT) && !defined(NO_OPENSSL) && !defined(RELEASE_CRUNCH)
+ DPADD+= ${LIBCRYPTO}
+ LDADD+= -lcrypto