summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/ucspi-unix/ucspi-unix-0.36.ebuild')
-rw-r--r--sys-apps/ucspi-unix/ucspi-unix-0.36.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/sys-apps/ucspi-unix/ucspi-unix-0.36.ebuild b/sys-apps/ucspi-unix/ucspi-unix-0.36.ebuild
index ab96f4b0e676..98d0bd51bb7c 100644
--- a/sys-apps/ucspi-unix/ucspi-unix-0.36.ebuild
+++ b/sys-apps/ucspi-unix/ucspi-unix-0.36.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/ucspi-unix/ucspi-unix-0.36.ebuild,v 1.3 2003/09/10 04:40:14 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/ucspi-unix/ucspi-unix-0.36.ebuild,v 1.4 2003/12/27 00:03:39 weeve Exp $
S=${WORKDIR}/${P}
DESCRIPTION="A ucspi implementation for unix sockets."
@@ -8,10 +8,18 @@ SRC_URI="http://untroubled.org/ucspi-unix/${P}.tar.gz"
DEPEND=">=dev-libs/bglibs-1.009"
HOMEPAGE="http://untroubled.org/ucspi-unix/"
-KEYWORDS="x86 amd64"
+KEYWORDS="x86 amd64 ~sparc"
SLOT="0"
LICENSE="GPL-2"
+src_unpack() {
+ unpack ${A}
+
+ # Fix for head syntax in Makefile
+ cd ${S}
+ epatch ${FILESDIR}/${PN}-gentoo-head.patch
+}
+
src_compile() {
echo "gcc ${CFLAGS} -I/usr/lib/bglibs/include" > conf-cc
echo "gcc -s -L/usr/lib/bglibs/lib" > conf-ld