summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/systemd/systemd-43.ebuild')
-rw-r--r--sys-apps/systemd/systemd-43.ebuild38
1 files changed, 30 insertions, 8 deletions
diff --git a/sys-apps/systemd/systemd-43.ebuild b/sys-apps/systemd/systemd-43.ebuild
index 298a9a100357..2bb623de45b2 100644
--- a/sys-apps/systemd/systemd-43.ebuild
+++ b/sys-apps/systemd/systemd-43.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-43.ebuild,v 1.1 2012/02/23 16:16:53 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/systemd/systemd-43.ebuild,v 1.2 2012/03/08 18:13:14 mgorny Exp $
EAPI=4
@@ -13,11 +13,10 @@ SRC_URI="http://www.freedesktop.org/software/systemd/${P}.tar.xz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="acl audit cryptsetup lzma pam plymouth selinux tcpd"
-
-# We need to depend on sysvinit for sulogin which is used in the rescue
-# mode. Bug #399615.
+IUSE="acl audit cryptsetup gtk lzma pam plymouth selinux tcpd"
+# Vala-0.10 doesn't work with libnotify 0.7.1
+VALASLOT="0.14"
# A little higher than upstream requires
# but I had real trouble with 2.6.37 and systemd.
MINKV="2.6.38"
@@ -33,6 +32,13 @@ RDEPEND=">=sys-apps/dbus-1.4.10
acl? ( sys-apps/acl )
audit? ( >=sys-process/audit-2 )
cryptsetup? ( sys-fs/cryptsetup )
+ gtk? (
+ dev-libs/dbus-glib
+ >=dev-libs/glib-2.26
+ dev-libs/libgee:0
+ x11-libs/gtk+:2
+ >=x11-libs/libnotify-0.7
+ !sys-apps/systemd-ui )
lzma? ( app-arch/xz-utils )
pam? ( virtual/pam )
plymouth? ( sys-boot/plymouth )
@@ -43,13 +49,27 @@ DEPEND="${RDEPEND}
app-arch/xz-utils
dev-util/gperf
dev-util/intltool
+ gtk? ( dev-lang/vala:${VALASLOT} )
>=sys-kernel/linux-headers-${MINKV}"
+# Due to vala being broken.
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
pkg_setup() {
enewgroup lock # used by var-lock.mount
enewgroup tty 5 # used by mount-setup for /dev/pts
}
+src_prepare() {
+ # Force the rebuild of .vala sources
+ touch src/*.vala || die
+
+ # Fix hardcoded path in .vala.
+ sed -i -e 's:/lib/systemd:/usr/lib/systemd:g' src/*.vala || die
+
+ autotools-utils_src_prepare
+}
+
src_configure() {
local myeconfargs=(
--with-distro=gentoo
@@ -64,15 +84,18 @@ src_configure() {
$(use_enable acl)
$(use_enable audit)
$(use_enable cryptsetup libcryptsetup)
+ $(use_enable gtk)
$(use_enable lzma xz)
$(use_enable pam)
$(use_enable plymouth)
$(use_enable selinux)
$(use_enable tcpd tcpwrap)
- # now in sys-apps/systemd-ui
- --disable-gtk
)
+ if use gtk; then
+ export VALAC="$(type -p valac-${VALASLOT})"
+ fi
+
autotools-utils_src_configure
}
@@ -136,7 +159,6 @@ pkg_postinst() {
elog "be installed:"
optfeature 'dev-python/dbus-python' 'for systemd-analyze'
optfeature 'dev-python/pycairo[svg]' 'for systemd-analyze plotting ability'
- optfeature 'sys-apps/systemd-ui' 'for GTK+ systemadm UI and gnome-ask-password-agent'
elog
ewarn "Please note this is a work-in-progress and many packages in Gentoo"