summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/sandbox/sandbox-1.6-r2.ebuild')
-rw-r--r--sys-apps/sandbox/sandbox-1.6-r2.ebuild12
1 files changed, 4 insertions, 8 deletions
diff --git a/sys-apps/sandbox/sandbox-1.6-r2.ebuild b/sys-apps/sandbox/sandbox-1.6-r2.ebuild
index 007a7c16fac3..866cf5a13a55 100644
--- a/sys-apps/sandbox/sandbox-1.6-r2.ebuild
+++ b/sys-apps/sandbox/sandbox-1.6-r2.ebuild
@@ -1,13 +1,13 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/sandbox-1.6-r2.ebuild,v 1.15 2010/08/15 05:22:23 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/sandbox/sandbox-1.6-r2.ebuild,v 1.16 2012/02/05 04:50:08 vapier Exp $
#
# don't monkey with this ebuild unless contacting portage devs.
# period.
#
-inherit eutils flag-o-matic toolchain-funcs multilib
+inherit eutils flag-o-matic toolchain-funcs multilib unpacker
DESCRIPTION="sandbox'd LD_PRELOAD hack"
HOMEPAGE="http://www.gentoo.org/"
@@ -32,11 +32,7 @@ sandbox_death_notice() {
}
src_unpack() {
- unpack ${A}
- if [[ ! -d ${S} ]] ; then
- # When upgrading from older version, lzma unpack may not work #271543
- lzma -dc "${DISTDIR}/${A}" | tar xf - || die
- fi
+ unpacker_src_unpack
cd "${S}"
epatch "${FILESDIR}"/${P}-disable-qa-static.patch
epatch "${FILESDIR}"/${P}-disable-pthread.patch