summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/dbus/dbus-1.2.24-r2.ebuild')
-rw-r--r--sys-apps/dbus/dbus-1.2.24-r2.ebuild6
1 files changed, 4 insertions, 2 deletions
diff --git a/sys-apps/dbus/dbus-1.2.24-r2.ebuild b/sys-apps/dbus/dbus-1.2.24-r2.ebuild
index f6f3d3ef6c4d..aee9b3900a69 100644
--- a/sys-apps/dbus/dbus-1.2.24-r2.ebuild
+++ b/sys-apps/dbus/dbus-1.2.24-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/dbus-1.2.24-r2.ebuild,v 1.1 2010/09/09 23:09:05 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/dbus/dbus-1.2.24-r2.ebuild,v 1.2 2010/09/13 21:23:52 reavertm Exp $
EAPI="2"
@@ -142,7 +142,9 @@ src_install() {
# FIXME: split dtd's in dbus-dtd ebuild
emake DESTDIR="${D}" install || die "make install failed"
if use doc; then
- dohtml doc/*.html doc/api/html/* || die "dohtml failed"
+ dohtml -p api/ doc/api/html/* || die "dohtml api failed"
+ cd "${S}"
+ dohtml doc/*.html || die "dohtml failed"
fi
}