summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/seaview')
-rw-r--r--sci-biology/seaview/ChangeLog7
-rw-r--r--sci-biology/seaview/files/seaview-20071113-glibc-2.10.patch12
-rw-r--r--sci-biology/seaview/files/seaview.desktop9
-rw-r--r--sci-biology/seaview/seaview-4.1.ebuild75
-rw-r--r--sci-biology/seaview/seaview-4.2.12.ebuild17
-rw-r--r--sci-biology/seaview/seaview-4.2.3.ebuild78
-rw-r--r--sci-biology/seaview/seaview-4.2.5.ebuild19
7 files changed, 11 insertions, 206 deletions
diff --git a/sci-biology/seaview/ChangeLog b/sci-biology/seaview/ChangeLog
index 821246ca2c3b..7db88c97fde8 100644
--- a/sci-biology/seaview/ChangeLog
+++ b/sci-biology/seaview/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-biology/seaview
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/seaview/ChangeLog,v 1.38 2011/02/01 08:24:21 je_fro Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/seaview/ChangeLog,v 1.39 2011/02/22 16:53:39 scarabeus Exp $
+
+ 22 Feb 2011; Tomáš Chvátal <scarabeus@gentoo.org> -seaview-4.1.ebuild,
+ -seaview-4.2.3.ebuild, seaview-4.2.5.ebuild, seaview-4.2.12.ebuild,
+ -files/seaview-20071113-glibc-2.10.patch, -files/seaview.desktop:
+ Remove old. Say goodbye to pdflib pdf useflag.
01 Feb 2011; Jeff Gardner <je_fro@gentoo.org> seaview-4.2.12.ebuild:
Fix to use pkg-config instead of deprecated xft-config.
diff --git a/sci-biology/seaview/files/seaview-20071113-glibc-2.10.patch b/sci-biology/seaview/files/seaview-20071113-glibc-2.10.patch
deleted file mode 100644
index 9f64ea23a76b..000000000000
--- a/sci-biology/seaview/files/seaview-20071113-glibc-2.10.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -ur seaview.orig/seaview.cxx seaview/seaview.cxx
---- seaview.orig/seaview.cxx 2007-10-23 18:11:34.000000000 +0300
-+++ seaview/seaview.cxx 2009-09-04 12:22:13.000000000 +0300
-@@ -3924,7 +3924,7 @@
- if( clipboard_contains_alignment(clipboard) ) {
- char **seqs, **seqnames, **comments, *p, *message;
- int i, count, num, changedwname = FALSE;
-- p = strchr(clipboard, ':') + 1;
-+ p = const_cast<char*> (strchr(clipboard, ':') + 1);
- count = read_mase_seqs_header(p, &seqs, &seqnames,
- &comments, NULL, &message);
- if(count == 0) return;
diff --git a/sci-biology/seaview/files/seaview.desktop b/sci-biology/seaview/files/seaview.desktop
deleted file mode 100644
index 50bd8419a64a..000000000000
--- a/sci-biology/seaview/files/seaview.desktop
+++ /dev/null
@@ -1,9 +0,0 @@
-[Desktop Entry]
-Encoding=UTF-8
-Name=Seaview
-Comment=Multiple Sequence Alignment Tool
-Exec=seaview
-Icon=/usr/share/pixmaps/seaview.xpm
-Terminal=false
-Type=Application
-Categories=Application;Graphics;Science;
diff --git a/sci-biology/seaview/seaview-4.1.ebuild b/sci-biology/seaview/seaview-4.1.ebuild
deleted file mode 100644
index a5618198a266..000000000000
--- a/sci-biology/seaview/seaview-4.1.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/seaview/seaview-4.1.ebuild,v 1.3 2010/07/04 19:56:23 halcy0n Exp $
-
-EAPI="2"
-
-inherit toolchain-funcs multilib eutils
-
-DESCRIPTION="A graphical multiple sequence alignment editor"
-HOMEPAGE="http://pbil.univ-lyon1.fr/software/seaview.html"
-SRC_URI="ftp://pbil.univ-lyon1.fr/pub/mol_phylogeny/seaview/archive/${PN}_${PV}.tar.gz"
-
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+pdf +xft"
-
-DEPEND="x11-libs/fltk:1.1
- pdf? ( media-libs/pdflib )
- xft? ( x11-libs/libXft
- x11-libs/fltk[xft] )"
-RDEPEND="${DEPEND}
- sci-biology/clustalw
- || ( sci-libs/libmuscle sci-biology/muscle )
- sci-biology/phyml"
-
-S="${WORKDIR}/${PN}"
-
-src_prepare() {
- # respect CXXFLAGS (package uses them as CFLAGS)
- sed -i \
- -e "s:^CXX.*:CXX = $(tc-getCXX):" \
- -e "s:\$(OPT):${CXXFLAGS}:" \
- -e "s:^OPT:#OPT:" \
- -e "s:^#IFLTK .*:IFLTK = $(fltk-config --use-images --cxxflags):" \
- -e "s:^#LFLTK .*:LFLTK = $(fltk-config --use-images --ldflags):" \
- -e "s:^USE_XFT:#USE_XFT:" \
- -e "s:^#HELPFILE:HELPFILE:" \
- -e "s:^#PHYMLNAME:PHYMLNAME:" \
- Makefile || die "sed failed while editing Makefile"
-
- if use pdf; then
- sed -i \
- -e "s:PDF_PS_FLAGS = -DNO_PDF:#PDF_PS_FLAGS = -DNO_PDF:" \
- -e "s:PDF_PS = postscript:#PDF_PS = postscript:" \
- -e "s:#PDF_INC = \$(HOME)/PDFlibLite:PDF_INC = /usr/include:" \
- -e "s:#PDF_LIB = \$(HOME)/PDFlibLite:PDF_LIB = /usr/lib:" \
- -e "s:#PDF_PS = pdf:PDF_PS = pdf:" \
- -e "s:#PDF_PS_FLAGS = -I\$(PDF_INC):PDF_PS_FLAGS = -I\$(PDF_INC):" \
- -e "s:#LPDF = -L\$(PDF_LIB) -lpdf:LPDF = -L\$(PDF_LIB) -lpdf:" \
- Makefile || die "sed failed while editing Makefile to enable pdf output"
- fi
-
- if use xft; then
- sed -i \
- -e "s:^#USE_XFT .*:USE_XFT = -DUSE_XFT $(xft-config --cflags):" \
- -e "s:-lXft:$(xft-config --libs):" \
- Makefile || die "sed failed while editing Makefile to enable xft"
- fi
-}
-
-src_install() {
- dobin seaview || die
-
- # /usr/share/seaview/seaview.html is hardcoded in the binary, see Makefile
- insinto /usr/share/seaview
- doins example.nxs seaview.html
-
- insinto /usr/share/seaview/images
- doins seaview.xpm || die
-
- make_desktop_entry seaview Seaview
-
- doman seaview.1 || die
-}
diff --git a/sci-biology/seaview/seaview-4.2.12.ebuild b/sci-biology/seaview/seaview-4.2.12.ebuild
index 12439841e92f..17c7ff6db897 100644
--- a/sci-biology/seaview/seaview-4.2.12.ebuild
+++ b/sci-biology/seaview/seaview-4.2.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/seaview/seaview-4.2.12.ebuild,v 1.2 2011/02/01 08:24:21 je_fro Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/seaview/seaview-4.2.12.ebuild,v 1.3 2011/02/22 16:53:39 scarabeus Exp $
EAPI="2"
@@ -13,10 +13,9 @@ SRC_URI="ftp://pbil.univ-lyon1.fr/pub/mol_phylogeny/seaview/archive/${PN}_${PV}.
LICENSE="public-domain"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="+pdf +xft"
+IUSE="+xft"
DEPEND="x11-libs/fltk:1.1
- pdf? ( media-libs/pdflib )
xft? ( x11-libs/libXft
x11-libs/fltk:1.1[xft] )"
RDEPEND="${DEPEND}
@@ -39,18 +38,6 @@ src_prepare() {
-e "s:^#PHYMLNAME:PHYMLNAME:" \
Makefile || die "sed failed while editing Makefile"
- if use pdf; then
- sed -i \
- -e "s:PDF_PS_FLAGS = -DNO_PDF:#PDF_PS_FLAGS = -DNO_PDF:" \
- -e "s:PDF_PS = postscript:#PDF_PS = postscript:" \
- -e "s:#PDF_INC = \$(HOME)/PDFlibLite:PDF_INC = /usr/include:" \
- -e "s:#PDF_LIB = \$(HOME)/PDFlibLite:PDF_LIB = /usr/lib:" \
- -e "s:#PDF_PS = pdf:PDF_PS = pdf:" \
- -e "s:#PDF_PS_FLAGS = -I\$(PDF_INC):PDF_PS_FLAGS = -I\$(PDF_INC):" \
- -e "s:#LPDF = -L\$(PDF_LIB) -lpdf:LPDF = -L\$(PDF_LIB) -lpdf:" \
- Makefile || die "sed failed while editing Makefile to enable pdf output"
- fi
-
if use xft; then
sed -i \
-e "s:^#USE_XFT .*:USE_XFT = -DUSE_XFT $(pkg-config --cflags xft):" \
diff --git a/sci-biology/seaview/seaview-4.2.3.ebuild b/sci-biology/seaview/seaview-4.2.3.ebuild
deleted file mode 100644
index 5b666fd6d1ff..000000000000
--- a/sci-biology/seaview/seaview-4.2.3.ebuild
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/seaview/seaview-4.2.3.ebuild,v 1.1 2010/03/20 21:49:12 weaver Exp $
-
-EAPI="2"
-
-inherit toolchain-funcs multilib eutils base
-
-DESCRIPTION="A graphical multiple sequence alignment editor"
-HOMEPAGE="http://pbil.univ-lyon1.fr/software/seaview.html"
-SRC_URI="ftp://pbil.univ-lyon1.fr/pub/mol_phylogeny/seaview/archive/${PN}_${PV}.tar.gz"
-
-LICENSE="public-domain"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+pdf +xft"
-
-DEPEND="x11-libs/fltk:1.1
- pdf? ( media-libs/pdflib )
- xft? ( x11-libs/libXft
- x11-libs/fltk:1.1[xft] )"
-RDEPEND="${DEPEND}
- sci-biology/clustalw
- || ( sci-libs/libmuscle sci-biology/muscle )
- sci-biology/phyml"
-
-S="${WORKDIR}/${PN}"
-
-src_prepare() {
- # respect CXXFLAGS (package uses them as CFLAGS)
- sed -i \
- -e "s:^CXX.*:CXX = $(tc-getCXX):" \
- -e "s:\$(OPT):${CXXFLAGS}:" \
- -e "s:^OPT:#OPT:" \
- -e "s:^#IFLTK .*:IFLTK = $(fltk-config --use-images --cxxflags):" \
- -e "s:^#LFLTK .*:LFLTK = $(fltk-config --use-images --ldflags):" \
- -e "s:^USE_XFT:#USE_XFT:" \
- -e "s:^#HELPFILE:HELPFILE:" \
- -e "s:^#PHYMLNAME:PHYMLNAME:" \
- Makefile || die "sed failed while editing Makefile"
-
- if use pdf; then
- sed -i \
- -e "s:PDF_PS_FLAGS = -DNO_PDF:#PDF_PS_FLAGS = -DNO_PDF:" \
- -e "s:PDF_PS = postscript:#PDF_PS = postscript:" \
- -e "s:#PDF_INC = \$(HOME)/PDFlibLite:PDF_INC = /usr/include:" \
- -e "s:#PDF_LIB = \$(HOME)/PDFlibLite:PDF_LIB = /usr/lib:" \
- -e "s:#PDF_PS = pdf:PDF_PS = pdf:" \
- -e "s:#PDF_PS_FLAGS = -I\$(PDF_INC):PDF_PS_FLAGS = -I\$(PDF_INC):" \
- -e "s:#LPDF = -L\$(PDF_LIB) -lpdf:LPDF = -L\$(PDF_LIB) -lpdf:" \
- Makefile || die "sed failed while editing Makefile to enable pdf output"
- fi
-
- if use xft; then
- sed -i \
- -e "s:^#USE_XFT .*:USE_XFT = -DUSE_XFT $(xft-config --cflags):" \
- -e "s:-lXft:$(xft-config --libs):" \
- Makefile || die "sed failed while editing Makefile to enable xft"
- else
- sed -i -e "s:-lXft::" Makefile || die
- fi
- base_src_prepare
-}
-
-src_install() {
- dobin seaview || die
-
- # /usr/share/seaview/seaview.html is hardcoded in the binary, see Makefile
- insinto /usr/share/seaview
- doins example.nxs seaview.html
-
- insinto /usr/share/seaview/images
- doins seaview.xpm || die
-
- make_desktop_entry seaview Seaview
-
- doman seaview.1 || die
-}
diff --git a/sci-biology/seaview/seaview-4.2.5.ebuild b/sci-biology/seaview/seaview-4.2.5.ebuild
index 40de6eed14dd..88812ef224a7 100644
--- a/sci-biology/seaview/seaview-4.2.5.ebuild
+++ b/sci-biology/seaview/seaview-4.2.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/seaview/seaview-4.2.5.ebuild,v 1.3 2010/07/16 22:05:28 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/seaview/seaview-4.2.5.ebuild,v 1.4 2011/02/22 16:53:39 scarabeus Exp $
EAPI="2"
@@ -13,10 +13,9 @@ SRC_URI="ftp://pbil.univ-lyon1.fr/pub/mol_phylogeny/seaview/archive/${PN}_${PV}.
LICENSE="public-domain"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="+pdf +xft"
+IUSE="+xft"
DEPEND="x11-libs/fltk:1.1
- pdf? ( media-libs/pdflib )
xft? ( x11-libs/libXft
x11-libs/fltk:1.1[xft] )"
RDEPEND="${DEPEND}
@@ -39,18 +38,6 @@ src_prepare() {
-e "s:^#PHYMLNAME:PHYMLNAME:" \
Makefile || die "sed failed while editing Makefile"
- if use pdf; then
- sed -i \
- -e "s:PDF_PS_FLAGS = -DNO_PDF:#PDF_PS_FLAGS = -DNO_PDF:" \
- -e "s:PDF_PS = postscript:#PDF_PS = postscript:" \
- -e "s:#PDF_INC = \$(HOME)/PDFlibLite:PDF_INC = /usr/include:" \
- -e "s:#PDF_LIB = \$(HOME)/PDFlibLite:PDF_LIB = /usr/lib:" \
- -e "s:#PDF_PS = pdf:PDF_PS = pdf:" \
- -e "s:#PDF_PS_FLAGS = -I\$(PDF_INC):PDF_PS_FLAGS = -I\$(PDF_INC):" \
- -e "s:#LPDF = -L\$(PDF_LIB) -lpdf:LPDF = -L\$(PDF_LIB) -lpdf:" \
- Makefile || die "sed failed while editing Makefile to enable pdf output"
- fi
-
if use xft; then
sed -i \
-e "s:^#USE_XFT .*:USE_XFT = -DUSE_XFT $(xft-config --cflags):" \