summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/embassy-domsearch/files/embassy-domsearch-0.1.650_fix-build-system.patch')
-rw-r--r--sci-biology/embassy-domsearch/files/embassy-domsearch-0.1.650_fix-build-system.patch31
1 files changed, 20 insertions, 11 deletions
diff --git a/sci-biology/embassy-domsearch/files/embassy-domsearch-0.1.650_fix-build-system.patch b/sci-biology/embassy-domsearch/files/embassy-domsearch-0.1.650_fix-build-system.patch
index f3f4b3950100..d24857c8386d 100644
--- a/sci-biology/embassy-domsearch/files/embassy-domsearch-0.1.650_fix-build-system.patch
+++ b/sci-biology/embassy-domsearch/files/embassy-domsearch-0.1.650_fix-build-system.patch
@@ -1,6 +1,12 @@
---- DOMSEARCH-0.1.650/configure.ac
-+++ DOMSEARCH-0.1.650/configure.ac
-@@ -635,33 +635,6 @@
+ configure.ac | 49 +++++++------------------------------------------
+ src/Makefile.am | 6 ++----
+ 2 files changed, 9 insertions(+), 46 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index f0f97fa..d419d7d 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -635,33 +635,6 @@ AS_CASE([${host_os}],
@@ -34,7 +40,7 @@
dnl FIXME: This does no longer seem required with Autoconf 2.67?
dnl Intel MacOSX 10.6 puts X11 in a non-standard place
dnl AS_IF([test "x${with_x}" != "xno"],
-@@ -737,21 +710,6 @@
+@@ -737,21 +710,6 @@ AX_LIB_POSTGRESQL
@@ -56,21 +62,25 @@
dnl Test if --enable-localforce given
locallink="no"
embprefix="/usr/local"
-@@ -874,6 +832,11 @@
+@@ -874,6 +832,13 @@ AC_ARG_ENABLE([systemlibs],
AM_CONDITIONAL([ESYSTEMLIBS], [test "x${enable_systemlibs}" = "xyes"])
+AS_IF([test "x${enable_systemlibs}" = "xyes"],
+[
+dnl using system libraries
-+ PKG_CHECK_MODULES([PLPLOT], [plplotd])
++ PKG_CHECK_MODULES([PLPLOT], [plplotd],
++ [],[PKG_CHECK_MODULES([PLPLOT], [plplot])]
++ )
+])
# Enable the purify tool: --enable-purify, sets CC and LIBTOOL
---- DOMSEARCH-0.1.650/src/Makefile.am
-+++ DOMSEARCH-0.1.650/src/Makefile.am
-@@ -17,9 +17,7 @@
+diff --git a/src/Makefile.am b/src/Makefile.am
+index 9829ebd..433a5c5 100644
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -17,9 +17,7 @@ AM_CPPFLAGS = -I../../../nucleus -I../../../ajax/pcre \
-I../../../ajax/ensembl -I../../../ajax/ajaxdb \
-I../../../ajax/acd -I../../../plplot
else
@@ -81,11 +91,10 @@
endif
if ISSHARED
-@@ -62,5 +60,5 @@
+@@ -62,5 +60,5 @@ LDADD = ../../../nucleus/libnucleus.la ../../../ajax/acd/libacd.la \
../../../plplot/libeplplot.la $(XLIB)
else
LDADD = -L${embprefix}/lib -lnucleus -lacd -lajaxdb -lensembl -lajaxg \
- -lajax -lepcre $(NLADD) -leplplot $(XLIB)
+ -lajax $(NLADD) $(XLIB)
endif
-