summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/bedtools/bedtools-2.15.0.ebuild')
-rw-r--r--sci-biology/bedtools/bedtools-2.15.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sci-biology/bedtools/bedtools-2.15.0.ebuild b/sci-biology/bedtools/bedtools-2.15.0.ebuild
new file mode 100644
index 000000000000..69f825cbe108
--- /dev/null
+++ b/sci-biology/bedtools/bedtools-2.15.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/bedtools/bedtools-2.15.0.ebuild,v 1.1 2012/01/02 22:13:24 weaver Exp $
+
+EAPI=4
+
+inherit flag-o-matic
+
+DESCRIPTION="Tools for manipulation and analysis of BED, GFF/GTF, VCF, and SAM/BAM file formats"
+HOMEPAGE="http://code.google.com/p/bedtools/"
+SRC_URI="http://bedtools.googlecode.com/files/BEDTools.v${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+S="${WORKDIR}/BEDTools-Version-${PV}"
+
+src_prepare() {
+ filter-ldflags -Wl,--as-needed
+ sed -i \
+ -e '/export CXXFLAGS/ d' \
+ -e '/export CXX/ d' \
+ Makefile || die
+}
+
+src_install() {
+ dobin bin/*
+ dodoc README* RELEASE_HISTORY
+ insinto /usr/share/${PN}
+ doins -r genomes
+}