summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'rox-base')
-rw-r--r--rox-base/rox/ChangeLog6
-rw-r--r--rox-base/rox/files/digest-rox-2.2.03
-rw-r--r--rox-base/rox/files/rox-2.2.0-gcc4.patch20
-rw-r--r--rox-base/rox/rox-2.2.0.ebuild82
-rw-r--r--rox-base/rox/rox-2.3.ebuild4
5 files changed, 7 insertions, 108 deletions
diff --git a/rox-base/rox/ChangeLog b/rox-base/rox/ChangeLog
index f70beb87f35d..5c15d4d1b2e5 100644
--- a/rox-base/rox/ChangeLog
+++ b/rox-base/rox/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for rox-base/rox
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/rox-base/rox/ChangeLog,v 1.31 2007/02/09 03:21:16 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/rox-base/rox/ChangeLog,v 1.32 2007/02/10 20:10:49 lack Exp $
+
+ 10 Feb 2007; Jim Ramsay <lack@gentoo.org> -files/rox-2.2.0-gcc4.patch,
+ -rox-2.2.0.ebuild, rox-2.3.ebuild:
+ Updated with most recent stabilization for alpha, cleaned up old versions
09 Feb 2007; Chris Gianelloni <wolf31o2@gentoo.org> rox-2.3.ebuild,
rox-2.5-r1.ebuild:
diff --git a/rox-base/rox/files/digest-rox-2.2.0 b/rox-base/rox/files/digest-rox-2.2.0
deleted file mode 100644
index fbdb0f20dd9a..000000000000
--- a/rox-base/rox/files/digest-rox-2.2.0
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 0deefd9e7edd4e79cd0f18f423264ebb rox-2.2.0.tgz 2033724
-RMD160 6fe46202ddd3f04c07a0eaaabde88eb776c535dd rox-2.2.0.tgz 2033724
-SHA256 31bdaa795c4b166a665460289db8adaea2708bc67c1fe8b3d34a569a784d3d2a rox-2.2.0.tgz 2033724
diff --git a/rox-base/rox/files/rox-2.2.0-gcc4.patch b/rox-base/rox/files/rox-2.2.0-gcc4.patch
deleted file mode 100644
index 9d538293294b..000000000000
--- a/rox-base/rox/files/rox-2.2.0-gcc4.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-diff -Nur rox-2.2.0-orig/ROX-Filer/src/toolbar.c rox-2.2.0/ROX-Filer/src/toolbar.c
---- rox-2.2.0-orig/ROX-Filer/src/toolbar.c 2005-06-19 15:34:28.000000000 -0600
-+++ rox-2.2.0/ROX-Filer/src/toolbar.c 2005-06-19 15:35:36.000000000 -0600
-@@ -61,7 +61,6 @@
- Option o_toolbar, o_toolbar_info, o_toolbar_disable;
- Option o_toolbar_min_width;
-
--static GtkTooltips *tooltips = NULL;
- static FilerWindow *filer_window_being_counted;
-
- /* TRUE if the button presses (or released) should open a new window,
-@@ -175,8 +174,6 @@
- GTK_STOCK_CLOSE);
- option_add_int(&o_toolbar_min_width, "toolbar_min_width", 1);
- option_add_notify(option_notify);
--
-- tooltips = gtk_tooltips_new();
-
- option_register_widget("tool-options", build_tool_options);
- }
diff --git a/rox-base/rox/rox-2.2.0.ebuild b/rox-base/rox/rox-2.2.0.ebuild
deleted file mode 100644
index c5ebc0a019a4..000000000000
--- a/rox-base/rox/rox-2.2.0.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/rox-base/rox/rox-2.2.0.ebuild,v 1.9 2006/10/23 14:27:45 lack Exp $
-
-inherit eutils
-
-DESCRIPTION="ROX is a desktop environment, like GNOME, KDE and XFCE. It is an attempt to bring some of the good features from RISC OS to Unix and Linux."
-HOMEPAGE="http://rox.sourceforge.net/"
-SRC_URI="mirror://sourceforge/rox/${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86 ppc alpha sparc amd64"
-
-DEPEND=">=x11-libs/gtk+-2.2
- >=dev-libs/glib-2.2
- >=dev-libs/libxml2-2.4.23
- >=x11-misc/shared-mime-info-0.9
- >=dev-util/pkgconfig-0.20
- svg? ( gnome-base/librsvg )"
-
-RDEPEND=">=x11-libs/gtk+-2.2
- >=dev-libs/glib-2.2
- >=dev-libs/libxml2-2.4.23
- >=x11-misc/shared-mime-info-0.9
- svg? ( gnome-base/librsvg )"
-
-IUSE="svg"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${P}-gcc4.patch
-}
-
-src_compile() {
-# rm ROX-Filer/src/configure # see bug #26162
-
- # If the env variable PLATFORM is set, rox will build using that
- # string. This causes issues as while the package will compile fine,
- # it will try to rebuild it the first time rox is run because it will
- # not be able to find a proper executable to run.
- use sparc && unset PLATFORM
-
- cd ROX-Filer
-
- # Most rox self-compiles have a 'read' call to wait for the user to
- # press return if the compile fails.
- # Find and remove this:
- sed -i.bak -e 's/\<read WAIT\>/#read/' AppRun
-
- ./AppRun --compile || die "make failed"
- (cd src; make clean) > /dev/null
-
- # Restore the original AppRun
- mv AppRun.bak AppRun
-}
-
-src_install() {
- doman rox.1
-
- dodir /usr/bin
- cp -rf ROX-Filer/ ${D}/usr/share/
- echo "#!/bin/sh" > "${D}/usr/bin/rox"
- echo "exec /usr/share/ROX-Filer/AppRun \"\$@\"" >> "${D}/usr/bin/rox"
- chmod a+x ${D}/usr/bin/rox
-
- insinto /usr/share/mime/packages
- doins rox.xml
-
- dodir /usr/share/
- cp -rf Choices ${D}/usr/share/
- dodir /usr/share/Choices/Mime-icons
- keepdir /usr/share/Choices/Mime-icons
-
- dodir /usr/share/icons
- dosym /usr/share/ROX-Filer/ROX /usr/share/icons/ROX
-}
-
-pkg_postinst() {
- update-mime-database /usr/share/mime
-}
diff --git a/rox-base/rox/rox-2.3.ebuild b/rox-base/rox/rox-2.3.ebuild
index 6eb0de6d2973..0f20890be409 100644
--- a/rox-base/rox/rox-2.3.ebuild
+++ b/rox-base/rox/rox-2.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/rox-base/rox/rox-2.3.ebuild,v 1.4 2007/02/09 03:21:16 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/rox-base/rox/rox-2.3.ebuild,v 1.5 2007/02/10 20:10:49 lack Exp $
inherit eutils
@@ -13,7 +13,7 @@ SRC_URI="mirror://sourceforge/rox/${P}.tgz mirror://gentoo/${ROX_PATCH_FN}.bz2"
# mark all as testing
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha ~amd64 ~ppc ~sparc ~x86"
+KEYWORDS="alpha"
DEPEND=">=x11-libs/gtk+-2.4
>=dev-libs/libxml2-2.4.23