summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-www/apache/apache-2.0.47.ebuild')
-rw-r--r--net-www/apache/apache-2.0.47.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/net-www/apache/apache-2.0.47.ebuild b/net-www/apache/apache-2.0.47.ebuild
index 7fc2285641e1..cfb6adf7ce5f 100644
--- a/net-www/apache/apache-2.0.47.ebuild
+++ b/net-www/apache/apache-2.0.47.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.0.47.ebuild,v 1.10 2003/10/30 15:44:07 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-www/apache/apache-2.0.47.ebuild,v 1.11 2004/01/15 03:55:19 robbat2 Exp $
inherit flag-o-matic
has_version =sys-libs/glibc-2.2* && filter-flags -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
@@ -21,7 +21,7 @@ DEPEND="dev-util/yacc
dev-libs/openssl
berkdb? sys-libs/db
gdbm? sys-libs/gdbm
- ldap? =net-nds/openldap-2*"
+ !mips? ( ldap? =net-nds/openldap-2* )"
IUSE="berkdb gdbm ldap"
src_unpack() {
@@ -129,7 +129,7 @@ src_unpack() {
src_compile() {
local myconf
- use ldap && \
+ use !mips && use ldap && \
myconf="--with-ldap --enable-auth-ldap=shared --enable-ldap=shared"
select_modules_config || die "determining modules"
@@ -184,7 +184,7 @@ src_install () {
#protect the suexec binary
local gid=`getent group apache |cut -d: -f3`
[ -z "${gid}" ] && gid=81
- fowners root.${gid} /usr/sbin/suexec
+ fowners root:${gid} /usr/sbin/suexec
fperms 4710 /usr/sbin/suexec
#setup links in /etc/apache2
@@ -229,7 +229,7 @@ src_install () {
do
doins ${FILESDIR}/2.0.40/$i
done
- use ldap && doins ${FILESDIR}/2.0.40/46_mod_ldap.conf
+ use !mips && use ldap && doins ${FILESDIR}/2.0.40/46_mod_ldap.conf
#drop in a convenient link to the manual
local datadir=`getent passwd apache | cut -d: -f6`