summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/rtorrent/rtorrent-0.8.6.ebuild')
-rw-r--r--net-p2p/rtorrent/rtorrent-0.8.6.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/net-p2p/rtorrent/rtorrent-0.8.6.ebuild b/net-p2p/rtorrent/rtorrent-0.8.6.ebuild
index 784e5771c887..3f17d2d1ed1e 100644
--- a/net-p2p/rtorrent/rtorrent-0.8.6.ebuild
+++ b/net-p2p/rtorrent/rtorrent-0.8.6.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.8.6.ebuild,v 1.2 2009/12/28 20:35:30 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/rtorrent/rtorrent-0.8.6.ebuild,v 1.3 2010/01/21 11:19:34 cla Exp $
EAPI=2
+inherit eutils
+
DESCRIPTION="BitTorrent Client using libtorrent"
HOMEPAGE="http://libtorrent.rakshasa.no/"
SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
@@ -23,6 +25,10 @@ RDEPEND="${COMMON_DEPEND}
DEPEND="${COMMON_DEPEND}
dev-util/pkgconfig"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-canvas-fix.patch
+}
+
src_configure() {
econf \
--disable-dependency-tracking \