summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/ssvnc/files/ssvnc-1.0.25-build.patch')
-rw-r--r--net-misc/ssvnc/files/ssvnc-1.0.25-build.patch153
1 files changed, 153 insertions, 0 deletions
diff --git a/net-misc/ssvnc/files/ssvnc-1.0.25-build.patch b/net-misc/ssvnc/files/ssvnc-1.0.25-build.patch
new file mode 100644
index 000000000000..097c89c11998
--- /dev/null
+++ b/net-misc/ssvnc/files/ssvnc-1.0.25-build.patch
@@ -0,0 +1,153 @@
+--- a/vnc_unixsrc/libvncauth/vncauth.c
++++ b/vnc_unixsrc/libvncauth/vncauth.c
+@@ -29,6 +29,7 @@
+ #include <unistd.h>
+ #include <vncauth.h>
+ #include <d3des.h>
++#include <time.h>
+
+ #include <fcntl.h>
+
+--- a/vnc_unixsrc/vncviewer/fullscreen.c
++++ b/vnc_unixsrc/vncviewer/fullscreen.c
+@@ -21,6 +21,7 @@
+ * fullscreen.c - functions to deal with full-screen mode.
+ */
+
++#include <time.h>
+ #include <vncviewer.h>
+ #include <X11/Xaw/Form.h>
+ #include <X11/Xaw/Viewport.h>
+--- a/vnc_unixsrc/vncviewer/misc.c
++++ b/vnc_unixsrc/vncviewer/misc.c
+@@ -24,6 +24,7 @@
+ #include <vncviewer.h>
+ #include <signal.h>
+ #include <fcntl.h>
++#include <sys/wait.h>
+
+ static void CleanupSignalHandler(int sig);
+ static int CleanupXErrorHandler(Display *dpy, XErrorEvent *error);
+--- a/vnc_unixsrc/vncviewer/popup.c
++++ b/vnc_unixsrc/vncviewer/popup.c
+@@ -22,6 +22,8 @@
+ */
+
+ #include "vncviewer.h"
++#include <sys/wait.h>
++#include <time.h>
+
+ #include <X11/Xaw/Form.h>
+ #include <X11/Xaw/Command.h>
+--- a/vnc_unixsrc/vncviewer/rfbproto.c
++++ b/vnc_unixsrc/vncviewer/rfbproto.c
+@@ -23,6 +23,8 @@
+ * rfbproto.c - functions to deal with client side of RFB protocol.
+ */
+
++#include <ctype.h>
++#include <time.h>
+ #include <sys/stat.h>
+ #include <unistd.h>
+ #include <errno.h>
+--- a/vnc_unixsrc/vncviewer/sockets.c
++++ b/vnc_unixsrc/vncviewer/sockets.c
+@@ -31,6 +31,7 @@
+ #include <netdb.h>
+ #include <fcntl.h>
+ #include <assert.h>
++#include <time.h>
+ #include <vncviewer.h>
+
+ /* Solaris (sysv?) needs INADDR_NONE */
+--- a/vnc_unixsrc/vncviewer/vncviewer.c
++++ b/vnc_unixsrc/vncviewer/vncviewer.c
+@@ -21,6 +21,7 @@
+ * vncviewer.c - the Xt-based VNC viewer.
+ */
+
++#include <ctype.h>
+ #include "vncviewer.h"
+ #include <X11/Xaw/Toggle.h>
+
+--- a/vncstorepw/lim_accept.c
++++ b/vncstorepw/lim_accept.c
+@@ -6,6 +6,7 @@
+ #include <stdlib.h>
+ #include <time.h>
+ #include <errno.h>
++#include <unistd.h>
+
+ /* rename accept something else while we do the includes: */
+ #define accept __accept_5_Moos
+--- a/vncstorepw/unwrap.c
++++ b/vncstorepw/unwrap.c
+@@ -21,6 +21,7 @@
+ */
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <errno.h>
+
+ int db = 0;
+--- a/vncstorepw/vncauth.c
++++ b/vncstorepw/vncauth.c
+@@ -1,5 +1,6 @@
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+ #include <sys/stat.h>
+ #include "d3des.h"
+ #if 0
+--- a/vncstorepw/vncstorepw.c
++++ b/vncstorepw/vncstorepw.c
+@@ -1,4 +1,5 @@
+ #include <stdio.h>
++#include <stdlib.h>
+
+ extern int rfbEncryptAndStorePasswd(char *, char*);
+
+--- a/Makefile
++++ b/Makefile
+@@ -21,11 +21,11 @@
+
+ # N.B. ?= is gnu make specific. Some of the subdir Makefiles are too.
+ #
+-PREFIX ?= /usr/local
+-ROOT ?=
++PREFIX = /usr
++ROOT = $(DESTDIR)
+ BIN = bin
+ LIB = lib/ssvnc
+ MAN = man
+-MANDIR ?= $(MAN)
++MANDIR = share/$(MAN)
+ APPS ?= share/applications
+ BINNAME ?= ssvncviewer
+@@ -66,7 +66,6 @@
+
+ install: all
+ mkdir -p $(ROOT)$(PREFIX)/$(BIN) $(ROOT)$(PREFIX)/$(LIB) $(ROOT)$(PREFIX)/$(MANDIR)/man1
+- strip $(VIEWER)
+ cp -p $(VIEWER) $(ROOT)$(PREFIX)/$(LIB)
+ cp -p $(VNCSPW) $(ROOT)$(PREFIX)/$(LIB)
+ cp -p $(UNWRAP) $(ROOT)$(PREFIX)/$(LIB)
+--- a/vncstorepw/Makefile
++++ b/vncstorepw/Makefile
+@@ -14,7 +14,6 @@
+
+ $(CMD): vncauth.o vncstorepw.o d3des.o
+ PATH=$$PATH:$(EPATH) $(CC) -o $(CMD) vncstorepw.o vncauth.o d3des.o
+- PATH=$$PATH:$(EPATH) strip $(CMD)
+ @ls -l $(CMD)
+
+ $(UNWRAP): unwrap.c
+@@ -41,7 +40,6 @@
+ else \
+ PATH=$$PATH:$(EPATH) $(CC) -o $(ULTDSM) $(CPP_SSL) ultravnc_dsm_helper.c $(LD_SSL) -lcrypto; \
+ fi
+- PATH=$$PATH:$(EPATH) strip $(ULTDSM)
+ @ls -l $(ULTDSM)
+
+ test: $(CMD)
+