summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/sitecopy/sitecopy-0.12.1.ebuild')
-rw-r--r--net-misc/sitecopy/sitecopy-0.12.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-misc/sitecopy/sitecopy-0.12.1.ebuild b/net-misc/sitecopy/sitecopy-0.12.1.ebuild
new file mode 100644
index 000000000000..ee20d033dd4d
--- /dev/null
+++ b/net-misc/sitecopy/sitecopy-0.12.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/sitecopy/sitecopy-0.12.1.ebuild,v 1.1 2003/04/28 18:37:19 mholzer Exp $
+
+IUSE="ssl xml xml2"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="sitecopy is for easily maintaining remote web sites"
+SRC_URI="http://www.lyra.org/${PN}/${P}.tar.gz"
+HOMEPAGE="http://www.lyra.org/sitecopy/"
+KEYWORDS="~x86 ~ppc ~sparc"
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="virtual/glibc
+ >=sys-libs/zlib-1.1.3
+ xml? ( dev-libs/libxml )
+ dev-libs/libxml2
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
+
+src_compile() {
+ local myconf=""
+ if [ "`use xml`" ] && [ "`use xml2`" ] ; then
+ myconf="${myconf} --with-libxml2 --without-libxml1"
+ else
+ use xml \
+ && myconf="${myconf} --with-libxml1" \
+ || myconf="${myconf} --without-libxml1"
+ use xml2 \
+ && myconf="${myconf} --with-libxml2" \
+ || myconf="${myconf} --without-libxml2"
+ fi
+ use ssl \
+ && myconf="${myconf} --with-ssl" \
+ || myconf="${myconf} --without-ssl"
+ econf ${myconf}
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "install failed"
+}