summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/redir/redir-2.2.1.ebuild')
-rw-r--r--net-misc/redir/redir-2.2.1.ebuild18
1 files changed, 11 insertions, 7 deletions
diff --git a/net-misc/redir/redir-2.2.1.ebuild b/net-misc/redir/redir-2.2.1.ebuild
index bfc809826915..98577aac662a 100644
--- a/net-misc/redir/redir-2.2.1.ebuild
+++ b/net-misc/redir/redir-2.2.1.ebuild
@@ -1,23 +1,27 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-misc/redir/redir-2.2.1.ebuild,v 1.7 2005/06/08 15:00:40 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-misc/redir/redir-2.2.1.ebuild,v 1.8 2009/05/30 02:00:17 darkside Exp $
+
+inherit toolchain-funcs
DESCRIPTION="Redir is a port redirector."
HOMEPAGE="http://sammy.net/~sammy/hacks/"
SRC_URI="http://sammy.net/~sammy/hacks/${P}.tar.gz"
+
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ~amd64 alpha ~hppa ~mips sparc"
+KEYWORDS="alpha ~amd64 ~hppa ~mips sparc x86"
IUSE=""
+
DEPEND=""
RDEPEND=""
src_compile() {
- emake || die
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" || die "emake failed"
}
src_install() {
- dobin redir
- newman redir.man redir.1
- dodoc CHANGES COPYING README transproxy.txt
+ dobin redir || die "dobin failed"
+ newman redir.man redir.1 || die "doman failed"
+ dodoc CHANGES README transproxy.txt || die "dodoc failed"
}