summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libssh/ChangeLog7
-rw-r--r--net-libs/libssh/libssh-0.5.2.ebuild74
2 files changed, 5 insertions, 76 deletions
diff --git a/net-libs/libssh/ChangeLog b/net-libs/libssh/ChangeLog
index 3a5408c4d68b..bee883aa26f5 100644
--- a/net-libs/libssh/ChangeLog
+++ b/net-libs/libssh/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-libs/libssh
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libssh/ChangeLog,v 1.70 2012/12/03 11:14:57 nativemad Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libssh/ChangeLog,v 1.71 2013/01/15 23:50:10 radhermit Exp $
+
+ 15 Jan 2013; Tim Harder <radhermit@gentoo.org> -libssh-0.5.2.ebuild:
+ Remove old.
03 Dec 2012; Andreas Schuerch <nativemad@gentoo.org> libssh-0.5.3.ebuild:
x86 stable, see bug 444147. Thanks Dan Dexter for testing.
diff --git a/net-libs/libssh/libssh-0.5.2.ebuild b/net-libs/libssh/libssh-0.5.2.ebuild
deleted file mode 100644
index d6369c22337a..000000000000
--- a/net-libs/libssh/libssh-0.5.2.ebuild
+++ /dev/null
@@ -1,74 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libssh/libssh-0.5.2.ebuild,v 1.5 2012/09/20 11:49:34 scarabeus Exp $
-
-EAPI=4
-
-inherit eutils cmake-utils
-
-DESCRIPTION="Access a working SSH implementation by means of a library"
-HOMEPAGE="http://www.libssh.org/"
-SRC_URI="https://red.libssh.org/attachments/download/27/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-KEYWORDS="amd64 ~arm ~hppa ppc ppc64 ~s390 ~sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
-SLOT="0"
-IUSE="debug doc examples gcrypt pcap +sftp ssh1 server static-libs test zlib"
-# Maintainer: check IUSE-defaults at DefineOptions.cmake
-
-RDEPEND="
- zlib? ( >=sys-libs/zlib-1.2 )
- !gcrypt? ( >=dev-libs/openssl-0.9.8 )
- gcrypt? ( >=dev-libs/libgcrypt-1.4 )
-"
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen )
- test? ( dev-util/cmockery )
-"
-
-REQUIRED_USE="test? ( static-libs )"
-
-DOCS=( AUTHORS README ChangeLog )
-
-src_prepare() {
- # just install the examples do not compile them
- sed -i \
- -e '/add_subdirectory(examples)/s/^/#DONOTWANT/' \
- CMakeLists.txt || die
-
- epatch "${FILESDIR}"/${PN}-0.5.0-no-pdf-doc.patch \
- "${FILESDIR}"/${PN}-0.5.0-tests.patch
-}
-
-src_configure() {
- local mycmakeargs=(
- $(cmake-utils_use_with debug DEBUG_CALLTRACE)
- $(cmake-utils_use_with debug DEBUG_CRYPTO)
- $(cmake-utils_use_with gcrypt)
- $(cmake-utils_use_with pcap)
- $(cmake-utils_use_with server)
- $(cmake-utils_use_with sftp)
- $(cmake-utils_use_with ssh1)
- $(cmake-utils_use_with static-libs STATIC_LIB)
- $(cmake-utils_use_with test TESTING)
- $(cmake-utils_use_with zlib LIBZ)
- )
-
- cmake-utils_src_configure
-}
-
-src_compile() {
- cmake-utils_src_compile
- use doc && cmake-utils_src_compile doc
-}
-
-src_install() {
- cmake-utils_src_install
-
- use doc && dohtml -r "${CMAKE_BUILD_DIR}"/doc/html/*
-
- if use examples; then
- docinto examples
- dodoc examples/*.{c,h,cpp}
- fi
-}