summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/gssdp/gssdp-0.7.2.ebuild')
-rw-r--r--net-libs/gssdp/gssdp-0.7.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-libs/gssdp/gssdp-0.7.2.ebuild b/net-libs/gssdp/gssdp-0.7.2.ebuild
new file mode 100644
index 000000000000..196a78383e1d
--- /dev/null
+++ b/net-libs/gssdp/gssdp-0.7.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/gssdp/gssdp-0.7.2.ebuild,v 1.1 2010/07/21 10:43:52 ford_prefect Exp $
+
+EAPI=2
+
+DESCRIPTION="A GObject-based API for handling resource discovery and announcement over SSDP."
+HOMEPAGE="http://gupnp.org/"
+SRC_URI="http://gupnp.org/sources/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="+introspection"
+
+RDEPEND=">=dev-libs/glib-2.18:2
+ net-libs/libsoup:2.4[introspection?]
+ >=x11-libs/gtk+-2.12:2
+ introspection? ( >=dev-libs/gobject-introspection-0.6.4 )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+src_configure() {
+ econf \
+ $(use_enable introspection) \
+ --disable-dependency-tracking \
+ --disable-gtk-doc \
+ --with-html-dir=/usr/share/doc/${PF}/html
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS ChangeLog NEWS README
+}