summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-ftp/gftp/gftp-2.0.19.ebuild')
-rw-r--r--net-ftp/gftp/gftp-2.0.19.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-ftp/gftp/gftp-2.0.19.ebuild b/net-ftp/gftp/gftp-2.0.19.ebuild
new file mode 100644
index 000000000000..8e47b887655d
--- /dev/null
+++ b/net-ftp/gftp/gftp-2.0.19.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-ftp/gftp/gftp-2.0.19.ebuild,v 1.1 2008/12/01 03:23:24 leio Exp $
+
+inherit eutils
+
+DESCRIPTION="Gnome based FTP Client"
+SRC_URI="http://www.gftp.org/${P}.tar.bz2"
+HOMEPAGE="http://www.gftp.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="gtk ssl"
+
+RDEPEND=">=dev-libs/glib-2
+ sys-devel/gettext
+ sys-libs/ncurses
+ sys-libs/readline
+ gtk? ( >=x11-libs/gtk+-2 )
+ ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9"
+
+src_compile() {
+ econf $(use_enable gtk gtkport) $(use_enable ssl) || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc ChangeLog* README* THANKS TODO docs/USERS-GUIDE
+}