summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/wireshark/wireshark-1.6.9.ebuild')
-rw-r--r--net-analyzer/wireshark/wireshark-1.6.9.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/net-analyzer/wireshark/wireshark-1.6.9.ebuild b/net-analyzer/wireshark/wireshark-1.6.9.ebuild
index 1f3c68e49eed..52525b363a6a 100644
--- a/net-analyzer/wireshark/wireshark-1.6.9.ebuild
+++ b/net-analyzer/wireshark/wireshark-1.6.9.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-1.6.9.ebuild,v 1.4 2012/07/30 05:24:24 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-1.6.9.ebuild,v 1.5 2012/08/07 09:02:01 jer Exp $
EAPI="3"
PYTHON_DEPEND="python? 2"
-inherit eutils flag-o-matic python toolchain-funcs user
+inherit autotools eutils flag-o-matic python toolchain-funcs user
[[ -n ${PV#*_rc} && ${PV#*_rc} != ${PV} ]] && MY_P=${PN}-${PV/_} || MY_P=${P}
DESCRIPTION="A network protocol analyzer formerly known as ethereal"
@@ -47,7 +47,7 @@ DEPEND="${RDEPEND}
sys-devel/bison
sys-apps/sed
sys-devel/flex
- !!<net-analyzer/wireshark-1.6.0_rc1"
+"
S=${WORKDIR}/${MY_P}
@@ -103,7 +103,10 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.6.6-gtk-pcap.patch
+ epatch \
+ "${FILESDIR}"/${PN}-1.6.6-gtk-pcap.patch \
+ "${FILESDIR}"/${PN}-1.8.1-ldflags.patch
+ eautoreconf
}
src_configure() {