summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/fwlogwatch/fwlogwatch-1.2-r1.ebuild')
-rw-r--r--net-analyzer/fwlogwatch/fwlogwatch-1.2-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/net-analyzer/fwlogwatch/fwlogwatch-1.2-r1.ebuild b/net-analyzer/fwlogwatch/fwlogwatch-1.2-r1.ebuild
new file mode 100644
index 000000000000..b3c48086c156
--- /dev/null
+++ b/net-analyzer/fwlogwatch/fwlogwatch-1.2-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fwlogwatch/fwlogwatch-1.2-r1.ebuild,v 1.1 2011/08/01 02:31:27 jer Exp $
+
+EAPI="4"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A packet filter and firewall log analyzer"
+HOMEPAGE="http://fwlogwatch.inside-security.de/"
+SRC_URI="${HOMEPAGE}sw/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+LICENSE="GPL-1"
+SLOT="0"
+IUSE=""
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-1.1-make.patch \
+ "${FILESDIR}"/${PN}-1.2-overflow.patch
+}
+
+src_compile() {
+ tc-export CC
+ default
+}
+
+src_install() {
+ dosbin fwlogwatch
+ dosbin contrib/fwlw_notify
+ dosbin contrib/fwlw_respond
+ dodir /usr/share/fwlogwatch/contrib
+ insinto /usr/share/fwlogwatch/contrib
+
+ doins contrib/fwlogsummary.cgi
+ doins contrib/fwlogsummary_small.cgi
+ doins contrib/fwlogwatch.php
+ doins contrib
+
+ insinto /etc
+ doins fwlogwatch.config
+
+ dodoc AUTHORS ChangeLog CREDITS README
+ doman fwlogwatch.8
+}