summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/teamspeak-client-bin/teamspeak-client-bin-3.0.10.ebuild')
-rw-r--r--media-sound/teamspeak-client-bin/teamspeak-client-bin-3.0.10.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/media-sound/teamspeak-client-bin/teamspeak-client-bin-3.0.10.ebuild b/media-sound/teamspeak-client-bin/teamspeak-client-bin-3.0.10.ebuild
deleted file mode 100644
index 1c164520c8a8..000000000000
--- a/media-sound/teamspeak-client-bin/teamspeak-client-bin-3.0.10.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/teamspeak-client-bin/teamspeak-client-bin-3.0.10.ebuild,v 1.2 2013/04/15 12:54:05 tomwij Exp $
-
-EAPI=5
-
-inherit eutils unpacker
-
-DESCRIPTION="TeamSpeak Client - Voice Communication Software"
-HOMEPAGE="http://www.teamspeak.com/"
-LICENSE="teamspeak3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-RESTRICT="fetch mirror strip"
-
-SRC_URI="amd64? ( http://ftp.4players.de/pub/hosted/ts3/releases/${PV}/TeamSpeak3-Client-linux_amd64-${PV/_/-}.run )
- x86? ( http://ftp.4players.de/pub/hosted/ts3/releases/${PV}/TeamSpeak3-Client-linux_x86-${PV/_/-}.run )"
-
-RDEPEND="dev-qt/qtgui:4[accessibility,xinerama]
- dev-qt/qtsql:4"
-
-S="${WORKDIR}"
-
-pkg_nofetch() {
- if use amd64 ; then
- einfo "Please download TeamSpeak3-Client-linux_amd64-${PV/_/-}.run"
- elif use x86 ; then
- einfo "Please download TeamSpeak3-Client-linux_x86-${PV/_/-}.run"
- fi
- einfo "from ${HOMEPAGE}?page=downloads and place this"
- einfo "file in ${DISTDIR}"
-}
-
-src_prepare() {
- # Remove the qt-libraries as they just cause trouble with the system's Qt, see bug #328807.
- rm libQt* || die "Couldn't remove bundled Qt libraries."
-
- # Rename the tsclient to its shorter version, required by the teamspeak3 script we install.
- mv ts3client_linux_* ts3client || die "Couldn't rename ts3client to its shorter version."
-}
-
-src_install() {
- dodir /opt/teamspeak3-client
- insinto /opt/teamspeak3-client
- doins -r *
-
- fperms +x /opt/teamspeak3-client/ts3client
-
- exeinto /usr/bin
- doexe "${FILESDIR}/teamspeak3"
-
- make_desktop_entry teamspeak3 TeamSpeak3 \
- "/opt/teamspeak3-client/pluginsdk/docs/client_html/images/logo.png" \
- Network
-}