summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/festival/festival-1.4.2-r3.ebuild')
-rw-r--r--media-sound/festival/festival-1.4.2-r3.ebuild26
1 files changed, 13 insertions, 13 deletions
diff --git a/media-sound/festival/festival-1.4.2-r3.ebuild b/media-sound/festival/festival-1.4.2-r3.ebuild
index 1ed336a78e1a..b1ff66a15361 100644
--- a/media-sound/festival/festival-1.4.2-r3.ebuild
+++ b/media-sound/festival/festival-1.4.2-r3.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/festival/festival-1.4.2-r3.ebuild,v 1.2 2003/02/13 13:11:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/festival/festival-1.4.2-r3.ebuild,v 1.3 2003/09/07 00:06:04 msterret Exp $
S=${WORKDIR}/${PN}
T=${WORKDIR}/speech_tools
DESCRIPTION="Festival Text to Speech engine"
-GCCPV=`cc -dumpversion`
+GCCPV=`cc -dumpversion`
IUSE=""
HOMEPAGE="http://www.cstr.ed.ac.uk/"
SITE="http://www.speech.cs.cmu.edu/${PN}/cstr/${PN}/${PV}"
@@ -59,7 +59,7 @@ src_compile() {
sed -e '/^MODULE_LIBS/s/-ltermcap/-lncurses/' editline.mak.orig \
> editline.mak
pushd
-
+
# emake worked for me on SMP
#emake did not work for me because I had -j5. If there is anything greater than
#-j2, emake dies.
@@ -103,15 +103,15 @@ src_install() {
dobin text2wave
cd ${WORKDIR}/festival/lib/etc/unknown_Linux
dobin audsp
-
+
einfo ""
einfo "Please ignore errors about skipped directories. They are harmless."
einfo ""
-
+
# Install the main libraries
insinto /usr/lib/festival
doins ${WORKDIR}/festival/lib/*
-
+
# Install the dicts and vioces
FESTLIB=${WORKDIR}/festival/lib
DESTLIB=/usr/lib/festival
@@ -122,35 +122,35 @@ src_install() {
doins ${FESTLIB}/dicts/cmu/*
insinto ${DESTLIB}/dicts/oald
doins ${FESTLIB}/dicts/oald/*
-
+
FESTLIB=${WORKDIR}/festival/lib/voices/spanish/el_diphone
DESTLIB=/usr/lib/festival/voices/spanish/el_diphone
insinto ${DESTLIB}/festvox
doins ${FESTLIB}/festvox/*
insinto ${DESTLIB}/group
doins ${FESTLIB}/group/*
-
+
FESTLIB=${WORKDIR}/festival/lib/voices/english
DESTLIB=/usr/lib/festival/voices/english
insinto ${DESTLIB}/don_diphone
doins ${FESTLIB}/don_diphone/*
insinto ${DESTLIB}/don_diphone/festvox
doins ${FESTLIB}/don_diphone/festvox/*
-
+
insinto ${DESTLIB}/kal_diphone
doins ${FESTLIB}/kal_diphone/*
insinto ${DESTLIB}/kal_diphone/festvox
doins ${FESTLIB}/kal_diphone/festvox/*
insinto ${DESTLIB}/kal_diphone/group
doins ${FESTLIB}/kal_diphone/group/*
-
+
insinto ${DESTLIB}/ked_diphone
doins ${FESTLIB}/ked_diphone/*
insinto ${DESTLIB}/ked_diphone/festvox
doins ${FESTLIB}/ked_diphone/festvox/*
insinto ${DESTLIB}/ked_diphone/group
doins ${FESTLIB}/ked_diphone/group/*
-
+
insinto ${DESTLIB}/rab_diphone
doins ${FESTLIB}/rab_diphone/*
insinto ${DESTLIB}/rab_diphone/festvox
@@ -162,12 +162,12 @@ src_install() {
doins ${FESTLIB}/us1_mbrola/*
insinto ${DESTLIB}/us1_mbrola/festvox
doins ${FESTLIB}/us1_mbrola/festvox/*
-
+
insinto ${DESTLIB}/us2_mbrola
doins ${FESTLIB}/us2_mbrola/*
insinto ${DESTLIB}/us2_mbrola/festvox
doins ${FESTLIB}/us2_mbrola/festvox/*
-
+
insinto ${DESTLIB}/us3_mbrola
doins ${FESTLIB}/us3_mbrola/*
insinto ${DESTLIB}/us3_mbrola/festvox