summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/aumix')
-rw-r--r--media-sound/aumix/ChangeLog9
-rw-r--r--media-sound/aumix/aumix-2.9.ebuild59
2 files changed, 66 insertions, 2 deletions
diff --git a/media-sound/aumix/ChangeLog b/media-sound/aumix/ChangeLog
index 592627831ab4..4f40a0de2cb9 100644
--- a/media-sound/aumix/ChangeLog
+++ b/media-sound/aumix/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-sound/aumix
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/aumix/ChangeLog,v 1.66 2009/05/12 11:43:57 ssuominen Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/aumix/ChangeLog,v 1.67 2010/04/14 11:50:35 ssuominen Exp $
+
+*aumix-2.9 (14 Apr 2010)
+
+ 14 Apr 2010; Samuli Suominen <ssuominen@gentoo.org> +aumix-2.9.ebuild:
+ Version bump.
*aumix-2.8-r5 (12 May 2009)
diff --git a/media-sound/aumix/aumix-2.9.ebuild b/media-sound/aumix/aumix-2.9.ebuild
new file mode 100644
index 000000000000..cb19c797d4ef
--- /dev/null
+++ b/media-sound/aumix/aumix-2.9.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/aumix/aumix-2.9.ebuild,v 1.1 2010/04/14 11:50:35 ssuominen Exp $
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="Aumix volume/mixer control program"
+HOMEPAGE="http://jpj.net/~trevor/aumix.html"
+SRC_URI="http://jpj.net/~trevor/aumix/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE="gpm gtk nls"
+
+RDEPEND=">=sys-libs/ncurses-5.2
+ gpm? ( >=sys-libs/gpm-1.19.3 )
+ gtk? ( x11-libs/gtk+:2 )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ sys-apps/findutils
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ # 2.9 was released, none of this was applied. why?
+ epatch "${FILESDIR}"/${PN}-2.8-nohome.patch \
+ "${FILESDIR}"/${PN}-2.8-save_load.patch \
+ "${FILESDIR}"/${PN}-2.8-nls.patch \
+ "${FILESDIR}"/${PN}-2.8-mute.patch \
+ "${FILESDIR}"/${PN}-2.8-noninter_strncpy.patch
+
+ # Prevent autotools from rerunning, bug #70379.
+ find . -print0 |xargs -0 touch
+}
+
+src_configure() {
+ local myconf
+
+ use gtk || myconf="${myconf} --without-gtk"
+ use gpm || myconf="${myconf} --without-gpm"
+
+ econf \
+ $(use_enable nls) \
+ --without-gtk1 \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS BUGS ChangeLog NEWS README TODO
+
+ newinitd "${FILESDIR}"/aumix.rc6 aumix
+
+ if use gtk; then
+ doicon data/aumix.xpm
+ make_desktop_entry aumix Aumix aumix
+ fi
+}