summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/lensfun')
-rw-r--r--media-libs/lensfun/ChangeLog8
-rw-r--r--media-libs/lensfun/files/lensfun-0.2.5_p153-build.patch12
-rw-r--r--media-libs/lensfun/files/lensfun-0.2.5_p153-pc.patch6
-rw-r--r--media-libs/lensfun/files/lensfun-0.2.6-auxfun.patch11
-rw-r--r--media-libs/lensfun/lensfun-0.2.6.ebuild52
5 files changed, 76 insertions, 13 deletions
diff --git a/media-libs/lensfun/ChangeLog b/media-libs/lensfun/ChangeLog
index 5b7a77f14bd0..e73d0bab2a2c 100644
--- a/media-libs/lensfun/ChangeLog
+++ b/media-libs/lensfun/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-libs/lensfun
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/lensfun/ChangeLog,v 1.43 2012/05/29 16:39:52 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/lensfun/ChangeLog,v 1.44 2012/07/02 16:15:00 ssuominen Exp $
+
+*lensfun-0.2.6 (02 Jul 2012)
+
+ 02 Jul 2012; Samuli Suominen <ssuominen@gentoo.org> +lensfun-0.2.6.ebuild,
+ +files/lensfun-0.2.6-auxfun.patch:
+ Version bump.
29 May 2012; Alexis Ballier <aballier@gentoo.org>
lensfun-0.2.5_p153-r1.ebuild:
diff --git a/media-libs/lensfun/files/lensfun-0.2.5_p153-build.patch b/media-libs/lensfun/files/lensfun-0.2.5_p153-build.patch
index d204bc66f7a3..425031dd511f 100644
--- a/media-libs/lensfun/files/lensfun-0.2.5_p153-build.patch
+++ b/media-libs/lensfun/files/lensfun-0.2.5_p153-build.patch
@@ -1,7 +1,5 @@
-Index: docs/CMakeLists.txt
-===================================================================
---- docs/CMakeLists.txt (Revision 153)
-+++ docs/CMakeLists.txt (Arbeitskopie)
+--- docs/CMakeLists.txt
++++ docs/CMakeLists.txt
@@ -11,7 +11,7 @@
CONFIGURE_FILE(doxyfile.in.cmake ${DOXYFILE} @ONLY)
@@ -18,10 +16,8 @@ Index: docs/CMakeLists.txt
-FILE(GLOB doc_files "${CMAKE_DOC_OUT}/*.*")
-INSTALL(FILES ${doc_files} DESTINATION ${DOCDIR})
+INSTALL(DIRECTORY "${CMAKE_BINARY_DIR}/doc_doxygen/" DESTINATION ${DOCDIR})
-Index: CMakeLists.txt
-===================================================================
---- CMakeLists.txt (Revision 153)
-+++ CMakeLists.txt (Arbeitskopie)
+--- CMakeLists.txt
++++ CMakeLists.txt
@@ -30,7 +30,7 @@
# options controlling the build process
diff --git a/media-libs/lensfun/files/lensfun-0.2.5_p153-pc.patch b/media-libs/lensfun/files/lensfun-0.2.5_p153-pc.patch
index a74acf8fe70d..a68cf55521f5 100644
--- a/media-libs/lensfun/files/lensfun-0.2.5_p153-pc.patch
+++ b/media-libs/lensfun/files/lensfun-0.2.5_p153-pc.patch
@@ -1,7 +1,5 @@
-Index: libs/lensfun/CMakeLists.txt
-===================================================================
---- libs/lensfun/CMakeLists.txt (Revision 158)
-+++ libs/lensfun/CMakeLists.txt (Arbeitskopie)
+--- libs/lensfun/CMakeLists.txt
++++ libs/lensfun/CMakeLists.txt
@@ -26,3 +26,12 @@
RUNTIME DESTINATION ${BINDIR}
LIBRARY DESTINATION ${LIBDIR}
diff --git a/media-libs/lensfun/files/lensfun-0.2.6-auxfun.patch b/media-libs/lensfun/files/lensfun-0.2.6-auxfun.patch
new file mode 100644
index 000000000000..c8d989f745ab
--- /dev/null
+++ b/media-libs/lensfun/files/lensfun-0.2.6-auxfun.patch
@@ -0,0 +1,11 @@
+--- libs/auxfun/CMakeLists.txt
++++ libs/auxfun/CMakeLists.txt
+@@ -6,7 +6,7 @@
+ ADD_LIBRARY(auxfun SHARED ${AUXFUN_SRC})
+ ENDIF()
+
+-SET_TARGET_PROPERTIES(auxfun PROPERTIES VERSION "${VERSION_MAJOR}.${VERSION_MINOR}).${VERSION_MICRO}.${VERSION_BUGFIX}")
++SET_TARGET_PROPERTIES(auxfun PROPERTIES VERSION "${VERSION_MAJOR}.${VERSION_MINOR}.${VERSION_MICRO}.${VERSION_BUGFIX}")
+ TARGET_LINK_LIBRARIES(auxfun ${PNG_LIBRARY} ${ZLIB_LIBRARY})
+ INSTALL(TARGETS auxfun
+ RUNTIME DESTINATION ${BINDIR}
diff --git a/media-libs/lensfun/lensfun-0.2.6.ebuild b/media-libs/lensfun/lensfun-0.2.6.ebuild
new file mode 100644
index 000000000000..b3558a4cf502
--- /dev/null
+++ b/media-libs/lensfun/lensfun-0.2.6.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/lensfun/lensfun-0.2.6.ebuild,v 1.1 2012/07/02 16:15:00 ssuominen Exp $
+
+EAPI=4
+
+PYTHON_DEPEND="2:2.6"
+
+inherit cmake-utils multilib python
+
+DESCRIPTION="lensfun: A library for rectifying and simulating photographic lens distortions"
+HOMEPAGE="http://lensfun.berlios.de/"
+SRC_URI="mirror://berlios/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-3 CCPL-Attribution-ShareAlike-3.0" # See README for reasoning.
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd"
+IUSE="doc sse sse2"
+
+RDEPEND=">=dev-libs/glib-2.28
+ media-libs/libpng:0
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-auxfun.patch
+ "${FILESDIR}"/${PN}-0.2.5_p153-build.patch
+ "${FILESDIR}"/${PN}-0.2.5_p153-pc.patch
+ )
+
+DOCS=( README docs/mounts.txt )
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DDOCDIR=/usr/share/doc/${PF}/html
+ -DLIBDIR=$(get_libdir)
+ -DBUILD_AUXFUN=ON
+ $(cmake-utils_use_build doc)
+ $(cmake-utils_use_build sse FOR_SSE)
+ $(cmake-utils_use_build sse2 FOR_SSE2)
+ -DBUILD_STATIC=OFF
+ -DBUILD_TESTS=OFF
+ )
+
+ cmake-utils_src_configure
+}