summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/gdk-pixbuf/gdk-pixbuf-0.20.0.ebuild')
-rw-r--r--media-libs/gdk-pixbuf/gdk-pixbuf-0.20.0.ebuild59
1 files changed, 59 insertions, 0 deletions
diff --git a/media-libs/gdk-pixbuf/gdk-pixbuf-0.20.0.ebuild b/media-libs/gdk-pixbuf/gdk-pixbuf-0.20.0.ebuild
new file mode 100644
index 000000000000..ae2773940ead
--- /dev/null
+++ b/media-libs/gdk-pixbuf/gdk-pixbuf-0.20.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/media-libs/gdk-pixbuf/gdk-pixbuf-0.20.0.ebuild,v 1.1 2002/09/30 23:52:36 spider Exp $
+
+inherit virtualx libtool gnome.org
+
+S=${WORKDIR}/${P}
+DESCRIPTION="GNOME Image Library"
+HOMEPAGE="http://www.gtk.org/"
+
+DEPEND="media-libs/jpeg
+ media-libs/tiff
+ =x11-libs/gtk+-1.2*
+ >=media-libs/imlib-1.9.14-r1
+ >=media-libs/libpng-1.2.1
+ >=gnome-base/gnome-libs-1.4.1.2-r1
+ =sys-libs/db-1.85*"
+# We need gnome-libs here, else gnome support do not get compiled into
+# gdk-pixbuf (the GnomeCanvasPixbuf library )
+
+SLOT="0"
+LICENSE="GPL-2 LGPL-2"
+KEYWORDS="x86 ppc sparc sparc64 alpha"
+
+src_unpack() {
+
+ unpack ${A}
+
+ cp ${S}/demo/Makefile.in ${S}/demo/Makefile.in.orig
+ sed -e 's:LDADD = :LDADD = $(LIBJPEG) $(LIBTIFF) $(LIBPNG) :' \
+ ${S}/demo/Makefile.in.orig > ${S}/demo/Makefile.in
+}
+
+src_compile() {
+
+ #update libtool, else we get the "relink bug"
+ elibtoolize
+
+ econf --sysconfdir=/etc/X11/gdk-pixbuf || die
+
+ #build needs to be able to
+ #connect to an X display.
+ Xemake || die
+}
+
+src_install() {
+
+ einstall \
+ sysconfdir=${D}/etc/X11/gdk-pixbuf || die
+
+
+ dosed -e "s:${D}::g" /usr/bin/gdk-pixbuf-config
+ #fix permissions on the loaders
+ chmod a+rx ${D}/usr/lib/gdk-pixbuf/loaders
+ chmod a+r ${D}/usr/lib/gdk-pixbuf/loaders/*
+
+ dodoc AUTHORS COPYING* ChangeLog INSTALL README NEWS TODO
+}
+