summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/smokekde/smokekde-4.12.3.ebuild')
-rw-r--r--kde-base/smokekde/smokekde-4.12.3.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/kde-base/smokekde/smokekde-4.12.3.ebuild b/kde-base/smokekde/smokekde-4.12.3.ebuild
new file mode 100644
index 000000000000..d0095eac28d1
--- /dev/null
+++ b/kde-base/smokekde/smokekde-4.12.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/smokekde/smokekde-4.12.3.ebuild,v 1.1 2014/03/04 19:13:11 johu Exp $
+
+EAPI=5
+
+inherit kde4-base
+
+DESCRIPTION="Scripting Meta Object Kompiler Engine - KDE bindings"
+KEYWORDS=" ~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="attica debug kate okular semantic-desktop"
+HOMEPAGE="http://techbase.kde.org/Development/Languages/Smoke"
+
+DEPEND="
+ $(add_kdebase_dep kdelibs 'semantic-desktop?')
+ $(add_kdebase_dep smokeqt)
+ attica? ( dev-libs/libattica )
+ kate? ( $(add_kdebase_dep kate) )
+ okular? ( $(add_kdebase_dep okular) )
+ semantic-desktop? ( $(add_kdebase_dep kdepimlibs) )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with attica LibAttica)
+ $(cmake-utils_use_disable kate)
+ $(cmake-utils_use_with okular)
+ $(cmake-utils_use_with semantic-desktop Akonadi)
+ $(cmake-utils_use_with semantic-desktop KdepimLibs)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop Soprano)
+ )
+ kde4-base_src_configure
+}