summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/libkcddb/libkcddb-4.14.0.ebuild')
-rw-r--r--kde-base/libkcddb/libkcddb-4.14.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/kde-base/libkcddb/libkcddb-4.14.0.ebuild b/kde-base/libkcddb/libkcddb-4.14.0.ebuild
new file mode 100644
index 000000000000..9bc6c5c71e79
--- /dev/null
+++ b/kde-base/libkcddb/libkcddb-4.14.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/libkcddb/libkcddb-4.14.0.ebuild,v 1.1 2014/08/20 16:02:42 johu Exp $
+
+EAPI=5
+
+inherit kde4-base
+
+DESCRIPTION="KDE library for CDDB"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug musicbrainz"
+
+# tests require network access and compare static data with online data
+# bug 280996
+RESTRICT=test
+
+DEPEND="
+ musicbrainz? ( media-libs/musicbrainz:5 )
+"
+RDEPEND="${DEPEND}"
+
+KMSAVELIBS="true"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_with musicbrainz MusicBrainz5)
+ )
+
+ kde4-base_src_configure
+}