summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kinfocenter/kinfocenter-4.1.4.ebuild')
-rw-r--r--kde-base/kinfocenter/kinfocenter-4.1.4.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/kde-base/kinfocenter/kinfocenter-4.1.4.ebuild b/kde-base/kinfocenter/kinfocenter-4.1.4.ebuild
new file mode 100644
index 000000000000..ade8e4aa0164
--- /dev/null
+++ b/kde-base/kinfocenter/kinfocenter-4.1.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kinfocenter/kinfocenter-4.1.4.ebuild,v 1.1 2009/01/13 22:07:59 alexxy Exp $
+
+EAPI="2"
+
+KMNAME=kdebase
+KMMODULE=apps/${PN}
+OPENGL_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="The KDE Info Center"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="debug htmlhandbook ieee1394 opengl"
+
+DEPEND="ieee1394? ( sys-libs/libraw1394 )
+ opengl? ( virtual/glu virtual/opengl )"
+RDEPEND="${DEPEND}
+ sys-apps/pciutils
+ sys-apps/usbutils"
+
+KMEXTRACTONLY="apps/cmake/modules/"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with ieee1394 RAW1394)
+ $(cmake-utils_use_with opengl OpenGL)"
+
+ kde4-meta_src_configure
+}