summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kdm')
-rw-r--r--kde-base/kdm/ChangeLog8
-rw-r--r--kde-base/kdm/Manifest4
-rw-r--r--kde-base/kdm/files/digest-kdm-3.4.12
-rw-r--r--kde-base/kdm/kdm-3.4.1.ebuild63
4 files changed, 75 insertions, 2 deletions
diff --git a/kde-base/kdm/ChangeLog b/kde-base/kdm/ChangeLog
index c512bc23b9af..4eff32a5a651 100644
--- a/kde-base/kdm/ChangeLog
+++ b/kde-base/kdm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdm
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdm/ChangeLog,v 1.9 2005/04/27 19:13:54 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdm/ChangeLog,v 1.10 2005/05/25 21:23:06 danarmak Exp $
+
+*kdm-3.4.1 (25 May 2005)
+
+ 25 May 2005; Dan Armak <danarmak@gentoo.org> +kdm-3.4.1.ebuild:
+ Ebuilds for KDE 3.4.1. These are package.masked until 3.4.1 is actually
+ released. You can't get the tarballs yet.
27 Apr 2005; Markus Rothe <corsair@gentoo.org> kdm-3.4.0.ebuild:
Added ~ppc64 to KEYWORDS
diff --git a/kde-base/kdm/Manifest b/kde-base/kdm/Manifest
index 55fa5ee15742..a047bbcd7000 100644
--- a/kde-base/kdm/Manifest
+++ b/kde-base/kdm/Manifest
@@ -1,4 +1,6 @@
-MD5 1b89cd583d376b3613aed6bb60534a55 ChangeLog 1597
+MD5 910c711280606c0768534bb61b41c409 kdm-3.4.1.ebuild 2433
MD5 b743f2819610b03b97dab04eee735cb7 kdm-3.4.0.ebuild 2452
+MD5 1b89cd583d376b3613aed6bb60534a55 ChangeLog 1597
MD5 acc03a4b12bb0433a57e95bd253b9501 metadata.xml 156
MD5 54e17e8f38d377972c220f10357c9b2f files/digest-kdm-3.4.0 68
+MD5 2ed3f0976007ee8a8406f3f6422d66bf files/digest-kdm-3.4.1 136
diff --git a/kde-base/kdm/files/digest-kdm-3.4.1 b/kde-base/kdm/files/digest-kdm-3.4.1
new file mode 100644
index 000000000000..7a8ed33cbdb4
--- /dev/null
+++ b/kde-base/kdm/files/digest-kdm-3.4.1
@@ -0,0 +1,2 @@
+MD5 c88659e558ca98dc45377bf8ddfc26c9 kdebase-3.4.0.tar.bz2 22670772
+MD5 8fbe0b943721b79f2549064b580acdde kdebase-3.4.1.tar.bz2 22433034
diff --git a/kde-base/kdm/kdm-3.4.1.ebuild b/kde-base/kdm/kdm-3.4.1.ebuild
new file mode 100644
index 000000000000..34688762d9a0
--- /dev/null
+++ b/kde-base/kdm/kdm-3.4.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdm/kdm-3.4.1.ebuild,v 1.1 2005/05/25 21:23:06 danarmak Exp $
+
+KMNAME=kdebase
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="KDE login manager, similar to xdm and gdm"
+KEYWORDS="~x86 ~amd64"
+IUSE="pam"
+
+KMEXTRA="kdmlib/"
+KMEXTRACTONLY="libkonq/konq_defaults.h
+ kioslave/thumbnail/configure.in.in" # for the HAVE_LIBART test
+KMCOMPILEONLY="kcontrol/background"
+DEPEND="$DEPEND
+ pam? ( sys-libs/pam ~kde-base/kdebase-pam-4 )
+ $(deprange $PV $MAXKDEVER kde-base/kcontrol)"
+ # Requires the desktop background settings and kdm modules,
+ # so until we separate the kcontrol modules into separate ebuilds :-),
+ # there's a dep here
+
+
+src_compile() {
+ use pam \
+ && myconf="$myconf --with-pam=yes" \
+ || myconf="$myconf --with-pam=no --with-shadow"
+
+ kde-meta_src_compile myconf configure
+ kde_remove_flag kdm/kfrontend -fomit-frame-pointer
+ kde-meta_src_compile make
+}
+
+src_install() {
+ kde-meta_src_install
+ cd ${S}/kdm && make DESTDIR=${D} GENKDMCONF_FLAGS="--no-old --no-backup --no-in-notice" install
+
+ # We tell kdm to /use session files from /usr/share/xsessions.
+ # I've removed some other kdmrc mods from here, since it's not clear why
+ # the default aren't ok (and I'm not sure about the benefits of using
+ # the xdm configfiles under /etc/X11 instead of our own ones),
+ # and it's the Gentoo Way to avoid modifying upstream behaviour.
+ # Tell me if you don't like this. --danarmak
+ cd ${D}/${KDEDIR}/share/config/kdm || die
+ sed -i -e "s:#SessionsDirs=:SessionsDirs=/usr/share/xsessions\n#SessionsDirs=:" \
+ -e "s:#GreetFont=:GreetFont=Sans Serif,24,-1,5,50,0,0,0,0,0\n#GreetFont=:" \
+ -e "s:#StdFont=:StdFont=Sans Serif,12,-1,5,50,0,0,0,0,0\n#StdFont=:" \
+ -e "s:#FailFont=:FailFont=Sans Serif,12,-1,5,75,0,0,0,0,0\n#FailFont=:" \
+ -e "s:#AntiAliasing=:AntiAliasing=true\n#AntiAliasing=:" \
+ kdmrc
+}
+
+pkg_postinst() {
+ # set the default kdm face icon if it's not already set by the system admin
+ # because this is user-overrideable in that way, it's not in src_install
+ if [ ! -e "${ROOT}${KDEDIR}/share/apps/kdm/faces/.default.face.icon" ]; then
+ mkdir -p "${ROOT}${KDEDIR}/share/apps/kdm/faces"
+ cp "${ROOT}${KDEDIR}/share/apps/kdm/pics/users/default1.png" \
+ "${ROOT}${KDEDIR}/share/apps/kdm/faces/.default.face.icon"
+ fi
+}