summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/cantor/cantor-4.7.3.ebuild')
-rw-r--r--kde-base/cantor/cantor-4.7.3.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/kde-base/cantor/cantor-4.7.3.ebuild b/kde-base/cantor/cantor-4.7.3.ebuild
deleted file mode 100644
index 9149aaa38263..000000000000
--- a/kde-base/cantor/cantor-4.7.3.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/cantor/cantor-4.7.3.ebuild,v 1.3 2011/12/07 22:13:52 hwoarang Exp $
-
-EAPI=4
-
-KDE_HANDBOOK="optional"
-KDE_SCM="git"
-inherit kde4-base
-
-DESCRIPTION="KDE4 interface for doing mathematics and scientific computing"
-KEYWORDS="amd64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="debug ps +R"
-
-# TODO Add Sage Mathematics Software backend (http://www.sagemath.org)
-RDEPEND="
- ps? ( app-text/libspectre )
- R? ( dev-lang/R )
-"
-DEPEND="${RDEPEND}
- >=dev-cpp/eigen-2.0.3:2
-"
-
-# bug 386491
-RESTRICT="test"
-
-src_configure() {
- mycmakeargs+="
- $(cmake-utils_use_with ps LibSpectre)
- $(cmake-utils_use_with R)
- "
- kde4-base_src_configure
-}
-
-pkg_postinst() {
- kde4-base_pkg_postinst
-
- if ! use R; then
- echo
- ewarn "You have decided to build ${PN} with no backend."
- ewarn "To have this application functional, please do one of below:"
- ewarn " # emerge -va1 '='${CATEGORY}/${P} with 'R' USE flag enabled"
- ewarn " # emerge -vaDu sci-mathematics/maxima"
- echo
- fi
-}