summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy/spacehulk/spacehulk-1.4.99.ebuild')
-rw-r--r--games-strategy/spacehulk/spacehulk-1.4.99.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/games-strategy/spacehulk/spacehulk-1.4.99.ebuild b/games-strategy/spacehulk/spacehulk-1.4.99.ebuild
index 6692dded13b6..e297d869d715 100644
--- a/games-strategy/spacehulk/spacehulk-1.4.99.ebuild
+++ b/games-strategy/spacehulk/spacehulk-1.4.99.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/spacehulk/spacehulk-1.4.99.ebuild,v 1.7 2006/01/11 21:34:29 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/spacehulk/spacehulk-1.4.99.ebuild,v 1.8 2007/02/03 14:29:03 nyhm Exp $
-inherit games kde-functions
+inherit qt3 games
DESCRIPTION="A boardgame in the world of Warhammer 40k"
HOMEPAGE="http://r.vinot.free.fr/spacehulk/"
@@ -14,14 +14,12 @@ KEYWORDS="x86"
SLOT="0"
IUSE="xinerama"
-DEPEND="=x11-libs/qt-3*
- sys-libs/zlib
+DEPEND="$(qt_min_version 3.3)
media-libs/libpng
media-libs/jpeg
- media-libs/nas"
+ xinerama? ( x11-libs/libXinerama )"
src_compile() {
- set-qtdir 3
egamesconf \
$(use_with xinerama) \
|| die
@@ -29,8 +27,9 @@ src_compile() {
}
src_install() {
- egamesinstall || die
- cp -R ../themes/* "${D}${GAMES_DATADIR}/${PN}/themes" || die "cp failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
+ insinto "${GAMES_DATADIR}"/${PN}/themes
+ doins -r ../themes/* || die "doins failed"
dodoc AUTHORS ChangeLog README TODO
prepgamesdirs
}