summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-kids/gcompris/gcompris-8.4.12.ebuild')
-rw-r--r--games-kids/gcompris/gcompris-8.4.12.ebuild76
1 files changed, 0 insertions, 76 deletions
diff --git a/games-kids/gcompris/gcompris-8.4.12.ebuild b/games-kids/gcompris/gcompris-8.4.12.ebuild
deleted file mode 100644
index 9767b72e9ba1..000000000000
--- a/games-kids/gcompris/gcompris-8.4.12.ebuild
+++ /dev/null
@@ -1,76 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-kids/gcompris/gcompris-8.4.12.ebuild,v 1.4 2010/06/16 02:08:07 arfrever Exp $
-
-EAPI=2
-inherit autotools eutils python games
-
-DESCRIPTION="full featured educational application for children from 2 to 10"
-HOMEPAGE="http://gcompris.net/"
-SRC_URI="mirror://sourceforge/gcompris/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE="debug gnet python sqlite"
-
-RDEPEND="x11-libs/gtk+:2
- media-libs/gstreamer:0.10
- media-libs/gst-plugins-good
- media-plugins/gst-plugins-ogg
- media-plugins/gst-plugins-vorbis
- media-libs/libart_lgpl
- >=gnome-base/libgnomecanvas-2.3.6
- media-libs/sdl-mixer
- media-libs/libsdl
- dev-libs/libxml2
- dev-libs/popt
- virtual/libintl
- games-board/gnuchess
- gnet? ( net-libs/gnet:2 )
- python? (
- dev-lang/python[threads]
- dev-python/pygtk
- sqlite? ( dev-python/pysqlite:2 )
- )
- sqlite? ( dev-db/sqlite:3 )"
-DEPEND="${RDEPEND}
- dev-perl/XML-Parser
- sys-devel/gettext
- sys-apps/texinfo
- app-text/texi2html
- dev-util/pkgconfig"
-RDEPEND="${RDEPEND}
- media-gfx/tuxpaint
- sci-electronics/gnucap"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-build.patch
- cp /usr/share/gettext/config.rpath .
- eautoreconf
-}
-
-src_configure() {
- GNUCHESS="${GAMES_BINDIR}"/gnuchess \
- egamesconf \
- --disable-dependency-tracking \
- --datarootdir="${GAMES_DATADIR}" \
- --datadir="${GAMES_DATADIR}" \
- --localedir=/usr/share/locale \
- --infodir=/usr/share/info \
- --enable-xf86vidmode \
- $(use_with python python "$(PYTHON -a)") \
- $(use_enable debug) \
- $(use_enable gnet) \
- $(use_enable sqlite)
-}
-
-src_compile() {
- emake -j1 || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc AUTHORS ChangeLog NEWS README THANKS TODO
- prepgamesdirs
-}