summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/spout/spout-1.2.ebuild')
-rw-r--r--games-arcade/spout/spout-1.2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/games-arcade/spout/spout-1.2.ebuild b/games-arcade/spout/spout-1.2.ebuild
new file mode 100644
index 000000000000..de8ab24e0784
--- /dev/null
+++ b/games-arcade/spout/spout-1.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/spout/spout-1.2.ebuild,v 1.1 2004/07/21 08:23:16 mr_bones_ Exp $
+
+inherit eutils games
+
+MY_P="spout-unix-${PV}"
+DESCRIPTION="Abstract Japanese caveflier / shooter"
+HOMEPAGE="http://code.mizzenblog.com/index.php?cat=2"
+SRC_URI="http://code.mizzenblog.com/spout/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND="virtual/x11
+ >=media-libs/libsdl-1.2.6"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ dogamesbin spout || die "dogamesbin failed"
+ insinto /usr/share/pixmaps
+ doins spout.png
+ make_desktop_entry spout "Spout" spout.png
+ dodoc README
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ einfo "To play in fullscreen mode, do 'spout f'."
+ einfo "To play in a greater resolution, do 'spout x', where"
+ einfo "x is an integer; the larger x is, the higher the resolution."
+ echo
+ einto "To play:"
+ einfo "Accelerate - spacebar, enter, z, x"
+ einfo "Pause - escape"
+ einfo "Exit - shift+escape"
+ einfo "Rotate - left or right"
+ echo
+}