summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/abe/abe-1.1.ebuild')
-rw-r--r--games-arcade/abe/abe-1.1.ebuild12
1 files changed, 6 insertions, 6 deletions
diff --git a/games-arcade/abe/abe-1.1.ebuild b/games-arcade/abe/abe-1.1.ebuild
index c0bae6556955..940da2e921d1 100644
--- a/games-arcade/abe/abe-1.1.ebuild
+++ b/games-arcade/abe/abe-1.1.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/abe/abe-1.1.ebuild,v 1.2 2006/09/20 16:47:12 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/abe/abe-1.1.ebuild,v 1.3 2006/10/17 17:56:28 nyhm Exp $
-inherit eutils games
+inherit eutils toolchain-funcs games
DESCRIPTION="A scrolling, platform-jumping, key-collecting, ancient pyramid exploring game"
-HOMEPAGE="http://abe.sourceforge.net"
+HOMEPAGE="http://abe.sourceforge.net/"
SRC_URI="mirror://sourceforge/abe/${P}.tar.gz"
LICENSE="GPL-2"
@@ -18,17 +18,17 @@ DEPEND=">=media-libs/libsdl-1.2.3
src_unpack() {
unpack ${A}
+ cd "${S}"
sed -i \
-e "/^TR_CFLAGS/d" \
-e "/^TR_CXXFLAGS/d" \
- "${S}"/configure.in \
+ configure \
|| die "sed failed"
}
src_compile() {
- ./autogen.sh || die "autogen.sh failed"
egamesconf --with-data-dir="${GAMES_DATADIR}/${PN}" || die
- emake || die "emake failed"
+ emake CC=$(tc-getCC) || die "emake failed"
}
src_install() {