summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/scons/scons-0.0.7.ebuild')
-rw-r--r--dev-util/scons/scons-0.0.7.ebuild20
1 files changed, 11 insertions, 9 deletions
diff --git a/dev-util/scons/scons-0.0.7.ebuild b/dev-util/scons/scons-0.0.7.ebuild
index 8ae1d3d53116..722281285dc6 100644
--- a/dev-util/scons/scons-0.0.7.ebuild
+++ b/dev-util/scons/scons-0.0.7.ebuild
@@ -1,16 +1,18 @@
-# Copyright 1999-2001 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-util/scons/scons-0.0.7.ebuild,v 1.2 2002/07/11 06:30:25 drobbins Exp $
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/scons/scons-0.0.7.ebuild,v 1.3 2002/07/23 13:28:37 seemant Exp $
-S=${WORKDIR}/scons-0.07
+MY_P=${PN}-0.07
+S=${WORKDIR}/${MY_P}
DESCRIPTION="Extensible python-based build utility"
-SRC_URI="http://unc.dl.sourceforge.net/sourceforge/scons/scons-0.07.tar.gz
- http://telia.dl.sourceforge.net/sourceforge/scons/scons-0.07.tar.gz"
-
+SRC_URI="mirror://sourceforge/scons/${MY_P}.tar.gz"
HOMEPAGE="http://www.scons.org"
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="x86"
+
DEPEND=">=dev-lang/python-2.0"
-RDEPEND=">=dev-lang/python-2.0"
src_compile() {
python setup.py build
@@ -18,6 +20,6 @@ src_compile() {
src_install () {
python setup.py install --root=${D}
- dodoc {CHANGES,LICENSE,README,RELEASE}.txt PKG-INFO MANIFEST
+ dodoc *.txt PKG-INFO MANIFEST
doman scons.1
}