summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/perforce-proxy/perforce-proxy-2003.2.ebuild')
-rw-r--r--dev-util/perforce-proxy/perforce-proxy-2003.2.ebuild23
1 files changed, 12 insertions, 11 deletions
diff --git a/dev-util/perforce-proxy/perforce-proxy-2003.2.ebuild b/dev-util/perforce-proxy/perforce-proxy-2003.2.ebuild
index 0ba75e1a6417..796e3d222c39 100644
--- a/dev-util/perforce-proxy/perforce-proxy-2003.2.ebuild
+++ b/dev-util/perforce-proxy/perforce-proxy-2003.2.ebuild
@@ -1,24 +1,26 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/perforce-proxy/perforce-proxy-2003.2.ebuild,v 1.2 2004/04/26 01:41:51 vapier Exp $
+
+inherit eutils
DESCRIPTION="Proxy daemon for a commercial version control system"
HOMEPAGE="http://www.perforce.com/"
-URI_BASE="ftp://ftp.perforce.com/perforce/r03.2/"
-BIN_BASE="$URI_BASE/bin.linux24x86"
-DOC_BASE="$URI_BASE/doc"
-SRC_URI="${BIN_BASE}/p4p"
+SRC_URI="ftp://ftp.perforce.com/perforce/r03.2/bin.linux24x86/p4p"
+
LICENSE="perforce.pdf"
SLOT="0"
KEYWORDS="~x86"
IUSE=""
+RESTRICT="nomirror nostrip"
+
DEPEND="virtual/glibc"
-#RDEPEND=""
+
S=${WORKDIR}
-RESTRICT="nomirror nostrip"
-MY_FILES=$FILESDIR/perforce-proxy-2003.1/
-src_unpack ()
-{
+MY_FILES=${FILESDIR}/perforce-proxy-2003.1/
+
+src_unpack() {
# we have to copy all of the files from $DISTDIR, otherwise we get
# sandbox violations when trying to install
@@ -27,8 +29,7 @@ src_unpack ()
done
}
-src_install()
-{
+src_install() {
enewuser perforce
enewgroup perforce