summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/bustle/bustle-0.4.0.ebuild')
-rw-r--r--dev-util/bustle/bustle-0.4.0.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/dev-util/bustle/bustle-0.4.0.ebuild b/dev-util/bustle/bustle-0.4.0.ebuild
new file mode 100644
index 000000000000..6bf834c76349
--- /dev/null
+++ b/dev-util/bustle/bustle-0.4.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bustle/bustle-0.4.0.ebuild,v 1.1 2012/01/19 19:14:56 slyfox Exp $
+
+# ebuild generated by hackport 0.2.14
+
+EAPI=4
+
+CABAL_FEATURES="bin"
+inherit haskell-cabal toolchain-funcs
+
+DESCRIPTION="Draw pretty sequence diagrams of D-Bus traffic"
+HOMEPAGE="http://hackage.haskell.org/package/bustle"
+SRC_URI="http://willthompson.co.uk/${PN}/releases/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2 GPL-2" # bustle-dbus-monitor.c is GPL-2, rest is LGPL-2
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="net-libs/libpcap
+ sys-apps/dbus
+ x11-libs/cairo
+ x11-libs/pango
+ gnome-base/libglade:2.0"
+DEPEND="${RDEPEND}
+ dev-haskell/binary
+ >=dev-haskell/cabal-1.8
+ dev-haskell/cairo
+ =dev-haskell/dbus-core-0.9*
+ dev-haskell/glade
+ dev-haskell/glib
+ >dev-haskell/gtk-0.11
+ dev-haskell/mtl
+ dev-haskell/pango
+ dev-haskell/parsec
+ dev-haskell/pcap
+ dev-haskell/text
+ >=dev-lang/ghc-6.10.1"
+
+src_compile() {
+ # compile haskell part
+ cabal_src_compile || die "could not build haskell parts"
+
+ # compile C part
+ emake \
+ "CC=$(tc-getCC)" \
+ "CFLAGS=${CFLAGS}" \
+ "CPPFLAGS=${CPPFLAGS}" \
+ "LDFLAGS=${LDFLAGS}"
+}
+
+src_install() {
+ # install haskell part
+ cabal_src_install || die "could not install haskell parts"
+
+ dobin "${S}"/dist/build/bustle-pcap
+
+ dodoc README HACKING NEWS
+}