summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/acgmake/acgmake-1.2.ebuild')
-rw-r--r--dev-util/acgmake/acgmake-1.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-util/acgmake/acgmake-1.2.ebuild b/dev-util/acgmake/acgmake-1.2.ebuild
new file mode 100644
index 000000000000..32b6275273b1
--- /dev/null
+++ b/dev-util/acgmake/acgmake-1.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/acgmake/acgmake-1.2.ebuild,v 1.1 2006/09/18 20:08:42 dsd Exp $
+
+S=${WORKDIR}/${PN}
+DESCRIPTION="Build system for large projects"
+HOMEPAGE="http://www-i8.informatik.rwth-aachen.de/software/acgmake/html/index.html"
+SRC_URI="http://www-i8.informatik.rwth-aachen.de/software/acgmake/${P}.tgz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-shells/bash
+ sys-devel/make"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ find . -name 'CVS' -type d -print0 | xargs -0 rm -rf
+ sed -i "s:g++.*:g++:" configs/config.gcc-linux
+}
+
+src_install() {
+ insinto /usr/lib/misc/acgmake
+ doins Config Rules
+ cp -a bin configs modules ${D}/usr/lib/misc/acgmake
+
+ dosym ../lib/misc/acgmake/bin/acgmake /usr/bin/acgmake
+}
+