summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/whoosh/whoosh-2.5.4.ebuild')
-rw-r--r--dev-python/whoosh/whoosh-2.5.4.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-python/whoosh/whoosh-2.5.4.ebuild b/dev-python/whoosh/whoosh-2.5.4.ebuild
deleted file mode 100644
index e93c92df1ce4..000000000000
--- a/dev-python/whoosh/whoosh-2.5.4.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/whoosh/whoosh-2.5.4.ebuild,v 1.2 2014/03/31 20:47:43 mgorny Exp $
-
-EAPI="5"
-
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy pypy2_0 )
-
-MY_PN="Whoosh"
-
-inherit distutils-r1
-
-DESCRIPTION="Fast, pure-Python full text indexing, search and spell checking library"
-HOMEPAGE="http://bitbucket.org/mchaput/whoosh/wiki/Home/ http://pypi.python.org/pypi/Whoosh/"
-SRC_URI="mirror://pypi/W/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc test"
-
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-python_prepare_all() {
- # (backport from upstream)
- sed -i -e '/cmdclass/s:pytest:PyTest:' setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_install_all() {
- local DOCS=( README.txt )
- use doc && local HTML_DOCS=( docs/build/html/_sources/. )
- distutils-r1_python_install_all
-}
-
-python_test() {
- esetup.py test
-}