summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/python-distutils-extra')
-rw-r--r--dev-python/python-distutils-extra/ChangeLog8
-rw-r--r--dev-python/python-distutils-extra/python-distutils-extra-2.33-r1.ebuild46
2 files changed, 53 insertions, 1 deletions
diff --git a/dev-python/python-distutils-extra/ChangeLog b/dev-python/python-distutils-extra/ChangeLog
index a733148a2d52..580573ab3c96 100644
--- a/dev-python/python-distutils-extra/ChangeLog
+++ b/dev-python/python-distutils-extra/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/python-distutils-extra
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-distutils-extra/ChangeLog,v 1.22 2013/02/12 01:06:57 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-distutils-extra/ChangeLog,v 1.23 2013/02/24 15:26:57 mgorny Exp $
+
+*python-distutils-extra-2.33-r1 (24 Feb 2013)
+
+ 24 Feb 2013; Michał Górny <mgorny@gentoo.org>
+ +python-distutils-extra-2.33-r1.ebuild:
+ Migrate the older version to distutils-r1 as required by x11-terms/terra.
*python-distutils-extra-2.37-r1 (12 Feb 2013)
diff --git a/dev-python/python-distutils-extra/python-distutils-extra-2.33-r1.ebuild b/dev-python/python-distutils-extra/python-distutils-extra-2.33-r1.ebuild
new file mode 100644
index 000000000000..b79801f29f0b
--- /dev/null
+++ b/dev-python/python-distutils-extra/python-distutils-extra-2.33-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-distutils-extra/python-distutils-extra-2.33-r1.ebuild,v 1.1 2013/02/24 15:26:57 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7} pypy{1_9,2_0} )
+
+inherit distutils-r1
+
+DESCRIPTION="Gettext support, themed icons and scrollkeeper-based documentation in distutils"
+HOMEPAGE="https://launchpad.net/python-distutils-extra"
+SRC_URI="http://launchpad.net/python-distutils-extra/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+DOCS=( doc/{FAQ,README,setup.cfg.example,setup.py.example} )
+
+python_prepare_all() {
+ # Disable broken tests.
+ sed \
+ -e "s/test_desktop/_&/" \
+ -e "s/test_po(/_&/" \
+ -e "s/test_policykit/_&/" \
+ -e "s/test_requires_provides/_&/" \
+ -i test/auto.py
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # 5 tests fail with disabled byte-compilation (they rely on exact
+ # output from python).
+ local -x PYTHONDONTWRITEBYTECODE
+
+ cp -R -l test "${BUILD_DIR}"/ || die
+
+ cd "${BUILD_DIR}" || die
+ "${PYTHON}" test/auto.py || die "Tests fail with ${EPYTHON}"
+}