summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pmw')
-rw-r--r--dev-python/pmw/ChangeLog6
-rw-r--r--dev-python/pmw/pmw-1.3.2-r2.ebuild12
-rw-r--r--dev-python/pmw/pmw-1.3.3.ebuild7
-rw-r--r--dev-python/pmw/pmw-2.0.0.ebuild9
4 files changed, 23 insertions, 11 deletions
diff --git a/dev-python/pmw/ChangeLog b/dev-python/pmw/ChangeLog
index 0041d2f31ad8..8129d602c4f6 100644
--- a/dev-python/pmw/ChangeLog
+++ b/dev-python/pmw/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pmw
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pmw/ChangeLog,v 1.36 2013/01/21 13:52:57 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pmw/ChangeLog,v 1.37 2013/01/29 12:35:56 jlec Exp $
+
+ 29 Jan 2013; Justin Lecher <jlec@gentoo.org> pmw-1.3.2-r2.ebuild,
+ pmw-1.3.3.ebuild, pmw-2.0.0.ebuild:
+ Correct SLOTs, #453570
*pmw-2.0.0 (21 Jan 2013)
*pmw-1.3.3 (21 Jan 2013)
diff --git a/dev-python/pmw/pmw-1.3.2-r2.ebuild b/dev-python/pmw/pmw-1.3.2-r2.ebuild
index 17f29a342ee5..4dcffd212ce8 100644
--- a/dev-python/pmw/pmw-1.3.2-r2.ebuild
+++ b/dev-python/pmw/pmw-1.3.2-r2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pmw/pmw-1.3.2-r2.ebuild,v 1.9 2012/02/21 07:08:54 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pmw/pmw-1.3.2-r2.ebuild,v 1.10 2013/01/29 12:35:56 jlec Exp $
EAPI="3"
PYTHON_DEPEND="2"
@@ -12,7 +12,7 @@ inherit distutils eutils
MY_P="Pmw.${PV}"
-DESCRIPTION="A toolkit for building high-level compound widgets in Python using the Tkinter module."
+DESCRIPTION="Toolkit for building high-level compound widgets in Python using the Tkinter module"
HOMEPAGE="http://pmw.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
@@ -21,8 +21,10 @@ SLOT="0"
KEYWORDS="alpha amd64 ia64 ppc sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
IUSE="doc examples"
-DEPEND=""
-RDEPEND=""
+DEPEND="
+ !dev-python/pmw:py2
+ !dev-python/pmw:py3"
+RDEPEND="${DEPEND}"
S="${WORKDIR}/${MY_P}/src"
diff --git a/dev-python/pmw/pmw-1.3.3.ebuild b/dev-python/pmw/pmw-1.3.3.ebuild
index 2d73d1074f75..4e2e942042c0 100644
--- a/dev-python/pmw/pmw-1.3.3.ebuild
+++ b/dev-python/pmw/pmw-1.3.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pmw/pmw-1.3.3.ebuild,v 1.1 2013/01/21 13:52:57 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pmw/pmw-1.3.3.ebuild,v 1.2 2013/01/29 12:35:56 jlec Exp $
EAPI=5
@@ -16,10 +16,13 @@ HOMEPAGE="http://pmw.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
LICENSE="BSD"
-SLOT="0"
+SLOT="py2"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
IUSE="doc examples"
+DEPEND="!dev-python/pmw:0"
+RDEPEND="${DEPEND}"
+
S="${WORKDIR}/src"
DOCS="Pmw/README"
diff --git a/dev-python/pmw/pmw-2.0.0.ebuild b/dev-python/pmw/pmw-2.0.0.ebuild
index 959d4897f6cf..fe2e5dbc025f 100644
--- a/dev-python/pmw/pmw-2.0.0.ebuild
+++ b/dev-python/pmw/pmw-2.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pmw/pmw-2.0.0.ebuild,v 1.1 2013/01/21 13:52:57 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pmw/pmw-2.0.0.ebuild,v 1.2 2013/01/29 12:35:56 jlec Exp $
EAPI=5
@@ -16,10 +16,13 @@ HOMEPAGE="http://pmw.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
LICENSE="BSD"
-SLOT="0"
-KEYWORDS=""
+SLOT="py3"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
IUSE="doc examples"
+DEPEND="!dev-python/pmw:0"
+RDEPEND="${DEPEND}"
+
S="${WORKDIR}/src"
DOCS="Pmw/README"