summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/numpy')
-rw-r--r--dev-python/numpy/ChangeLog6
-rw-r--r--dev-python/numpy/numpy-1.5.1.ebuild5
2 files changed, 6 insertions, 5 deletions
diff --git a/dev-python/numpy/ChangeLog b/dev-python/numpy/ChangeLog
index 7d8e6f68de2a..df360e248aea 100644
--- a/dev-python/numpy/ChangeLog
+++ b/dev-python/numpy/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/numpy
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/ChangeLog,v 1.123 2010/12/18 21:38:49 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/ChangeLog,v 1.124 2010/12/18 22:05:37 arfrever Exp $
+
+ 18 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ numpy-1.5.1.ebuild:
+ Run tests with Python 3.
18 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
-numpy-1.5.0-r2.ebuild, -files/numpy-1.5.0-python3.patch:
diff --git a/dev-python/numpy/numpy-1.5.1.ebuild b/dev-python/numpy/numpy-1.5.1.ebuild
index 7ee9eccae5ba..1b49af4f1cb1 100644
--- a/dev-python/numpy/numpy-1.5.1.ebuild
+++ b/dev-python/numpy/numpy-1.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/numpy-1.5.1.ebuild,v 1.1 2010/11/19 04:35:55 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/numpy-1.5.1.ebuild,v 1.2 2010/12/18 22:05:37 arfrever Exp $
EAPI="3"
PYTHON_DEPEND="*"
@@ -117,9 +117,6 @@ src_compile() {
src_test() {
testing() {
- # Disable tests with Python 3 until dev-python/nose supports Python 3.
- [[ "$(python_get_version --major)" == 3 ]] && return
-
"$(PYTHON)" setup.py ${NUMPY_FCONFIG} build -b "build-${PYTHON_ABI}" install \
--home="${S}/test-${PYTHON_ABI}" --no-compile || die "install test failed"
pushd "${S}/test-${PYTHON_ABI}/"lib* > /dev/null