summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/lxml')
-rw-r--r--dev-python/lxml/Manifest3
-rw-r--r--dev-python/lxml/files/lxml-2.2.4-python-2.7.patch31
-rw-r--r--dev-python/lxml/lxml-2.2.4.ebuild85
3 files changed, 0 insertions, 119 deletions
diff --git a/dev-python/lxml/Manifest b/dev-python/lxml/Manifest
index f269f04af7c0..78fb8efcf99d 100644
--- a/dev-python/lxml/Manifest
+++ b/dev-python/lxml/Manifest
@@ -1,8 +1,5 @@
-AUX lxml-2.2.4-python-2.7.patch 807 RMD160 8322eef2a2a6e0ab8032fa3a59fe2300cc673c2a SHA1 929cc7a45de1d02876b7d7981629e11f449b4776 SHA256 a4d5e00fbebc19b15c308b2f77ff3e5aa908c7c1b9f5a6f79c1a46b3a26269f2
AUX lxml-2.2.4-python-3.patch 1270 RMD160 16a79e8e05ee0f0f682340bde63d3e3c6cb8819b SHA1 f03dedccab36df33ba1d043f9378730240d7b00f SHA256 a254619109f84b06e188ea2b148ce3ebe5a9cc81da73eb746a85731ee91c882b
-DIST lxml-2.2.4.tgz 2964382 RMD160 b7abdd8faee1ef1b2f1868fb188a2faea25a012e SHA1 da97ed375268363ad40501bcfc6980a6c5100d5e SHA256 5b21daabdfcd3c7b6498bf9074d5bd2217665d792e21ecc573d572f7eadc4ab7
DIST lxml-2.2.6.tgz 2923134 RMD160 6f8cded975cf10b1dd79db22a9f912eaea86363c SHA1 340d8cee8b787e9b2d2ab8ba2ab268460efa9232 SHA256 7fd36e4a56360cd5d7319e357b04a90e2c6b836ea220c88f9451c300ae33cc5e
-EBUILD lxml-2.2.4.ebuild 2196 RMD160 6f0dd55930e353f669f1d7abd9e9a88e8b763538 SHA1 fd08ab1b34e41cf2771450dd672d249cebc56095 SHA256 902dc68768624a4e32022a2bbb3f73788175395210eabf2daa227cfebc5679c2
EBUILD lxml-2.2.6.ebuild 2167 RMD160 4c7ed474131ebd962795f85598d4079c61ba5eb8 SHA1 013631ca15322b532eaf743a0f1061897807d47f SHA256 e961d0814032a5594cb6802492cb740973025b11ee4e7bdcda6a6727cb4f182e
MISC ChangeLog 10720 RMD160 a1e27dc6e72ef390fdd2e491840feb13d5fa34e8 SHA1 f3be3a39858ebb5a62f2928824993378de4a4816 SHA256 258566c293d50b9692c076fa43ba8dc9071c0b58206a6a2ef5535b82f167d671
MISC metadata.xml 159 RMD160 900a8c55d7a7d2f6312594769aaf941bf9e99c7f SHA1 c8e604d56dae898258b5254d78cfeac0b981e288 SHA256 9f01104d3484792496faff4805eed0ecea2352a897151f3397d49a13800037b4
diff --git a/dev-python/lxml/files/lxml-2.2.4-python-2.7.patch b/dev-python/lxml/files/lxml-2.2.4-python-2.7.patch
deleted file mode 100644
index 540e8b6dd571..000000000000
--- a/dev-python/lxml/files/lxml-2.2.4-python-2.7.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- test.py
-+++ test.py
-@@ -75,6 +75,11 @@
- set
- except NameError:
- from sets import Set as set
-+try:
-+ # Python >=2.7 and >=3.2
-+ from unittest.runner import _TextTestResult
-+except ImportError:
-+ from unittest import _TextTestResult
-
- __metaclass__ = type
-
-@@ -302,14 +307,14 @@
- return results
-
-
--class CustomTestResult(unittest._TextTestResult):
-+class CustomTestResult(_TextTestResult):
- """Customised TestResult.
-
- It can show a progress bar, and displays tracebacks for errors and failures
- as soon as they happen, in addition to listing them all at the end.
- """
-
-- __super = unittest._TextTestResult
-+ __super = _TextTestResult
- __super_init = __super.__init__
- __super_startTest = __super.startTest
- __super_stopTest = __super.stopTest
diff --git a/dev-python/lxml/lxml-2.2.4.ebuild b/dev-python/lxml/lxml-2.2.4.ebuild
deleted file mode 100644
index 87d0f9ba1a4a..000000000000
--- a/dev-python/lxml/lxml-2.2.4.ebuild
+++ /dev/null
@@ -1,85 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/lxml/lxml-2.2.4.ebuild,v 1.11 2010/03/06 20:01:06 armin76 Exp $
-
-EAPI="2"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils eutils flag-o-matic
-
-DESCRIPTION="A Pythonic binding for the libxml2 and libxslt libraries"
-HOMEPAGE="http://codespeak.net/lxml/ http://pypi.python.org/pypi/lxml"
-SRC_URI="http://codespeak.net/lxml/${P}.tgz"
-
-LICENSE="BSD ElementTree GPL-2 PSF-2.4"
-SLOT="0"
-KEYWORDS="amd64 hppa ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE="doc examples +threads"
-
-RDEPEND=">=dev-libs/libxml2-2.7.2
- >=dev-libs/libxslt-1.1.15
- >=dev-python/beautifulsoup-3.0.8"
-DEPEND="${RDEPEND}
- >=dev-python/setuptools-0.6_rc5"
-# lxml tarball contains files pregenerated by Cython.
-
-pkg_setup() {
- # Tests fail with some optimizations.
- replace-flags -O[2-9s]* -O1
-}
-
-src_prepare() {
- distutils_src_prepare
-
- # Disable broken tests.
- sed -e "/elementsoup\.txt/d" -i src/lxml/html/tests/test_elementsoup.py || die "sed failed"
-
- epatch "${FILESDIR}/${P}-python-2.7.patch"
- epatch "${FILESDIR}/${P}-python-3.patch"
-}
-
-src_compile() {
- local myconf
- use threads || myconf+=" --without-threading"
- distutils_src_compile ${myconf}
-}
-
-src_test() {
- testing() {
- # Tests are broken with Python 3.
- [[ "${PYTHON_ABI}" == 3.* ]] && return
-
- local module
- for module in lxml/etree lxml/objectify; do
- ln -fs "../../$(ls -d build-${PYTHON_ABI}/lib.*)/${module}.so" "src/${module}.so" || die "ln -fs src/${module} failed"
- done
-
- local return_status="0" test
- for test in test.py selftest.py selftest2.py; do
- einfo "Running ${test}"
- if ! PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" "$(PYTHON)" "${test}"; then
- eerror "${test} failed with Python ${PYTHON_ABI}"
- return_status="1"
- fi
- done
-
- return "${return_status}"
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dohtml -r doc/html/*
- dodoc *.txt
- docinto doc
- dodoc doc/*.txt
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}/examples
- doins -r samples/*
- fi
-}