summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/defusedxml/defusedxml-0.4.1.ebuild')
-rw-r--r--dev-python/defusedxml/defusedxml-0.4.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/defusedxml/defusedxml-0.4.1.ebuild b/dev-python/defusedxml/defusedxml-0.4.1.ebuild
new file mode 100644
index 000000000000..0cbdf3e16fda
--- /dev/null
+++ b/dev-python/defusedxml/defusedxml-0.4.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/defusedxml/defusedxml-0.4.1.ebuild,v 1.1 2013/06/02 10:44:08 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_1,3_2,3_3} pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="XML bomb protection for Python stdlib modules, an xml serialiser"
+HOMEPAGE="https://bitbucket.org/tiran/defusedxml"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+LICENSE="PSF-2"
+SLOT="0"
+
+RDEPEND="dev-python/pyxml[$(python_gen_usedep python{2_6,2_7})]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+ esetup.py test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( other/. )
+ distutils-r1_python_install_all
+}