summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/astroid/astroid-1.2.1.ebuild')
-rw-r--r--dev-python/astroid/astroid-1.2.1.ebuild42
1 files changed, 0 insertions, 42 deletions
diff --git a/dev-python/astroid/astroid-1.2.1.ebuild b/dev-python/astroid/astroid-1.2.1.ebuild
deleted file mode 100644
index ccf7e05e7f96..000000000000
--- a/dev-python/astroid/astroid-1.2.1.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/astroid/astroid-1.2.1.ebuild,v 1.1 2014/09/10 09:35:33 idella4 Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="Abstract Syntax Tree for logilab packages"
-HOMEPAGE="http://bitbucket.org/logilab/astroid http://pypi.python.org/pypi/astroid"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x64-macos ~x86-macos"
-IUSE="test"
-
-# Version specified in __pkginfo__.py.
-RDEPEND=">=dev-python/logilab-common-0.60.0[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- app-arch/unzip
- test? ( ${RDEPEND}
- ~dev-python/pylint-1.3.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/egenix-mx-base[${PYTHON_USEDEP}]' python2_7) )"
-# Required for tests
-DISTUTILS_IN_SOURCE_BUILD=1
-
-# Restrict to test phase, required because suite fails horribly without it
-src_test() {
- local DISTUTILS_NO_PARALLEL_BUILD=1
- distutils-r1_src_test
-}
-
-python_test() {
- "${PYTHON}" setup.py build
-
- pushd build/lib > /dev/null
- PYTHONPATH=. pytest || die "Tests fail with ${EPYTHON}"
- popd > /dev/null
-}