summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/phpDocumentor/ChangeLog8
-rw-r--r--dev-php/phpDocumentor/phpDocumentor-2.2.0.ebuild7
-rw-r--r--dev-php/phpDocumentor/phpDocumentor-2.3.0.ebuild29
3 files changed, 40 insertions, 4 deletions
diff --git a/dev-php/phpDocumentor/ChangeLog b/dev-php/phpDocumentor/ChangeLog
index 7de1e9d2c5fd..187bce431b32 100644
--- a/dev-php/phpDocumentor/ChangeLog
+++ b/dev-php/phpDocumentor/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-php/phpDocumentor
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/phpDocumentor/ChangeLog,v 1.1 2014/01/08 15:42:38 mabi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/phpDocumentor/ChangeLog,v 1.2 2014/02/17 21:59:30 mabi Exp $
+
+*phpDocumentor-2.3.0 (17 Feb 2014)
+
+ 17 Feb 2014; Matti Bickel <mabi@gentoo.org> +phpDocumentor-2.3.0.ebuild,
+ phpDocumentor-2.2.0.ebuild:
+ version bump. update RDEPEND to include php extensions as stated by the README
*phpDocumentor-2.2.0 (08 Jan 2014)
diff --git a/dev-php/phpDocumentor/phpDocumentor-2.2.0.ebuild b/dev-php/phpDocumentor/phpDocumentor-2.2.0.ebuild
index 56d885be2a12..4e95369b9b31 100644
--- a/dev-php/phpDocumentor/phpDocumentor-2.2.0.ebuild
+++ b/dev-php/phpDocumentor/phpDocumentor-2.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/phpDocumentor/phpDocumentor-2.2.0.ebuild,v 1.1 2014/01/08 15:42:38 mabi Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-php/phpDocumentor/phpDocumentor-2.2.0.ebuild,v 1.2 2014/02/17 21:59:30 mabi Exp $
EAPI=5
@@ -17,8 +17,9 @@ KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
IUSE="doc"
# block old version that provides the same binary
-DEPEND="media-gfx/graphviz
- !dev-php/PEAR-PhpDocumentor"
+DEPEND="!dev-php/PEAR-PhpDocumentor"
+RDEPEND="media-gfx/graphviz
+ dev-lang/php[iconv,intl,xslt]"
src_install() {
php-pear-r1_src_install
diff --git a/dev-php/phpDocumentor/phpDocumentor-2.3.0.ebuild b/dev-php/phpDocumentor/phpDocumentor-2.3.0.ebuild
new file mode 100644
index 000000000000..a36c25f7b981
--- /dev/null
+++ b/dev-php/phpDocumentor/phpDocumentor-2.3.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/phpDocumentor/phpDocumentor-2.3.0.ebuild,v 1.1 2014/02/17 21:59:30 mabi Exp $
+
+EAPI=5
+
+PHP_PEAR_URI="pear.phpdoc.org"
+
+inherit php-pear-r1
+
+DESCRIPTION="The phpDocumentor package provides automatic documenting of php api directly from the source."
+
+LICENSE="MIT"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+# block old version that provides the same binary
+DEPEND="!dev-php/PEAR-PhpDocumentor"
+RDEPEND="media-gfx/graphviz
+ dev-lang/php[iconv,intl,xslt]"
+
+src_install() {
+ php-pear-r1_src_install
+
+ # install manual, tutorial, reference material
+ use doc && dodoc -r docs/*
+}