summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libtomcrypt/libtomcrypt-0.98-r1.ebuild')
-rw-r--r--dev-libs/libtomcrypt/libtomcrypt-0.98-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-libs/libtomcrypt/libtomcrypt-0.98-r1.ebuild b/dev-libs/libtomcrypt/libtomcrypt-0.98-r1.ebuild
new file mode 100644
index 000000000000..1b5fd026969f
--- /dev/null
+++ b/dev-libs/libtomcrypt/libtomcrypt-0.98-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libtomcrypt/libtomcrypt-0.98-r1.ebuild,v 1.1 2004/08/13 15:41:18 vapier Exp $
+
+inherit eutils
+
+DESCRIPTION="modular and portable cryptographic toolkit"
+HOMEPAGE="http://libtomcrypt.org/"
+SRC_URI="http://libtomcrypt.org/files/crypt-${PV}.tar.bz2
+ http://libtomcrypt.org/files/patch-${PV}/ltc-${PV}-001.tar.bz2"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="x86 ppc"
+IUSE="doc"
+
+DEPEND="doc? ( virtual/tetex app-text/ghostscript )"
+
+src_unpack() {
+ unpack crypt-${PV}.tar.bz2
+ mkdir patches && cd patches
+ unpack ltc-${PV}-001.tar.bz2
+ cd ${S}
+ epatch $(find ${WORKDIR}/patches -type f)
+ use doc || sed -i '/^install:/s:docs::' makefile
+}
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc authors changes
+ if use doc ; then
+ docinto examples ; dodoc examples/*
+ docinto notes ; dodoc notes/*
+ docinto demos ; dodoc demos/*
+ fi
+}