summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/cdk')
-rw-r--r--dev-libs/cdk/ChangeLog9
-rw-r--r--dev-libs/cdk/cdk-5.0.20141106.ebuild49
2 files changed, 56 insertions, 2 deletions
diff --git a/dev-libs/cdk/ChangeLog b/dev-libs/cdk/ChangeLog
index 46fdee6890d1..a0aa81df951c 100644
--- a/dev-libs/cdk/ChangeLog
+++ b/dev-libs/cdk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/cdk
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/cdk/ChangeLog,v 1.87 2014/06/25 05:05:45 radhermit Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cdk/ChangeLog,v 1.88 2015/01/28 01:45:29 radhermit Exp $
+
+*cdk-5.0.20141106 (28 Jan 2015)
+
+ 28 Jan 2015; Tim Harder <radhermit@gentoo.org> +cdk-5.0.20141106.ebuild:
+ Version bump.
*cdk-5.0.20140118 (25 Jun 2014)
diff --git a/dev-libs/cdk/cdk-5.0.20141106.ebuild b/dev-libs/cdk/cdk-5.0.20141106.ebuild
new file mode 100644
index 000000000000..9179f2524956
--- /dev/null
+++ b/dev-libs/cdk/cdk-5.0.20141106.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/cdk/cdk-5.0.20141106.ebuild,v 1.1 2015/01/28 01:45:29 radhermit Exp $
+
+EAPI=5
+
+inherit eutils versionator
+
+MY_P="${PN}-$(replace_version_separator 2 -)"
+DESCRIPTION="A library of curses widgets"
+HOMEPAGE="http://dickey.his.com/cdk/cdk.html"
+SRC_URI="ftp://invisible-island.net/cdk/${MY_P}.tgz"
+
+LICENSE="BSD"
+SLOT="0/6" # subslot = soname version
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="examples static-libs unicode"
+
+DEPEND=">=sys-libs/ncurses-5.2[unicode?]"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-5.0.20120323-parallel-make.patch
+}
+
+src_configure() {
+ econf \
+ --with-libtool \
+ --with-shared \
+ --with-ncurses$(usex unicode "w" "")
+}
+
+src_install() {
+ # parallel make installs duplicate libs
+ emake -j1 \
+ DESTDIR="${ED}" \
+ DOCUMENT_DIR="${ED}/usr/share/doc/${PF}" install
+
+ if use examples ; then
+ for x in include c++ demos examples cli cli/utils cli/samples; do
+ docinto $x
+ find $x -maxdepth 1 -mindepth 1 -type f -print0 | xargs -0 dodoc
+ done
+ fi
+
+ use static-libs || find "${ED}" \( -name '*.a' -or -name '*.la' \) -delete
+}