summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/swi-prolog/files/swi-prolog-packages-test-r1.patch')
-rw-r--r--dev-lang/swi-prolog/files/swi-prolog-packages-test-r1.patch190
1 files changed, 190 insertions, 0 deletions
diff --git a/dev-lang/swi-prolog/files/swi-prolog-packages-test-r1.patch b/dev-lang/swi-prolog/files/swi-prolog-packages-test-r1.patch
new file mode 100644
index 000000000000..9919dc2029c1
--- /dev/null
+++ b/dev-lang/swi-prolog/files/swi-prolog-packages-test-r1.patch
@@ -0,0 +1,190 @@
+--- pl-5.6.4.orig/packages/clib/configure.in 2006-01-11 09:41:55.000000000 +1300
++++ pl-5.6.4/packages/clib/configure.in 2006-02-13 23:41:14.000000000 +1300
+@@ -19,6 +19,7 @@
+ AC_SUBST(TARGETS)
+ AC_SUBST(PLTARGETS)
+ AC_SUBST(CRYPTLIBS)
++AC_SUBST(MT)
+
+ AC_ARG_ENABLE(mt, [ --enable-mt Enable Multi-threading],
+ [ case "$enableval" in
+--- pl-5.6.4.orig/packages/clib/Makefile.in 2006-02-04 04:38:49.000000000 +1300
++++ pl-5.6.4/packages/clib/Makefile.in 2006-02-13 23:43:17.000000000 +1300
+@@ -41,6 +41,8 @@
+ LD=@LD@
+ LDFLAGS=@LDSOFLAGS@
+
++CHECK_THREADS=@MT@
++
+ INSTALL=@INSTALL@
+ INSTALL_PROGRAM=@INSTALL_PROGRAM@
+ INSTALL_DATA=@INSTALL_DATA@
+@@ -123,7 +125,9 @@
+ torture: torture-socket
+
+ check-socket::
+- $(PL) -q -f testsocket.pl -F none -g tcp_test,halt -t 'halt(1)'
++ @if test "$(CHECK_THREADS)" = "yes" ; then \
++ $(PL) -q -f testsocket.pl -F none -g tcp_test,halt -t 'halt(1)' ; \
++ fi
+
+ torture-socket::
+ $(PL) -q -f stresssocket.pl -F none -g test,halt -t 'halt(1)'
+--- pl-5.6.4.orig/packages/semweb/configure.in 2006-02-07 04:59:54.000000000 +1300
++++ pl-5.6.4/packages/semweb/configure.in 2006-02-13 23:46:30.000000000 +1300
+@@ -17,13 +17,16 @@
+ AC_SUBST(SO)
+ AC_SUBST(LDSOFLAGS)
+ AC_SUBST(RUNTEX)
++AC_SUBST(ENABLE_CHECKS)
+
+ AC_ARG_ENABLE(mt, [ --enable-mt Enable Multi-threading],
+ [case "$enableval" in
+ yes) AC_DEFINE([_REENTRANT], 1,
+ [Define to prepare for multi-threading])
++ ENABLE_CHECKS="yes"
++ ;;
++ *) ENABLE_CHECKS="no"
+ ;;
+- *) ;;
+ esac])
+
+ if test -z "$PLINCL"; then
+--- pl-5.6.4.orig/packages/semweb/Makefile.in 2006-02-08 09:07:47.000000000 +1300
++++ pl-5.6.4/packages/semweb/Makefile.in 2006-02-13 23:48:32.000000000 +1300
+@@ -44,6 +44,8 @@
+ LD=@LD@
+ LDFLAGS=@LDSOFLAGS@
+
++ENABLE_CHECKS=@ENABLE_CHECKS@
++
+ INSTALL=@INSTALL@
+ INSTALL_PROGRAM=@INSTALL_PROGRAM@
+ INSTALL_DATA=@INSTALL_DATA@
+@@ -127,7 +129,9 @@
+ ################################################################
+
+ check::
+- $(PL) -q -f rdf_db_test.pl -g test,halt -t 'halt(1)'
+- $(PL) -q -f litmap_test.pl -g test,halt -t 'halt(1)'
++ @if test "$(ENABLE_CHECKS)" = "yes" ; then \
++ $(PL) -q -f rdf_db_test.pl -g test,halt -t 'halt(1)' ; \
++ $(PL) -q -f litmap_test.pl -g test,halt -t 'halt(1)' ; \
++ fi
+
+
+--- pl-5.6.9.orig/packages/ssl/ssl_test.pl 2006-02-14 04:27:41.000000000 +1300
++++ pl-5.6.9/packages/ssl/ssl_test.pl 2006-03-27 21:18:14.000000000 +1200
+@@ -130,8 +130,8 @@
+ ssl_init(SSL, client,
+ [ host('localhost'),
+ port(1111),
+-% cert(true),
+-% peer_cert(true),
++ cert(true),
++ peer_cert(true),
+ cacert_file('etc/demoCA/cacert.pem'),
+ certificate_file('etc/client/client-cert.pem'),
+ key_file('etc/client/client-key.pem'),
+--- pl-5.6.4.orig/packages/xpce/src/Makefile.in 2006-02-13 05:44:13.000000000 +1300
++++ pl-5.6.4/packages/xpce/src/Makefile.in 2006-02-13 23:59:59.000000000 +1300
+@@ -55,6 +55,7 @@
+ DESTDIR=
+
+ PCEHOME=@PCEHOME@
++PCEBUILD=$(PCEHOME)/src/xpce.sh
+ XINCLUDES=@XINCLUDES@
+ XLIB=@XLIB@
+
+@@ -896,7 +897,7 @@
+ ################################################################
+
+ check::
+- $(PLBUILD) -q -g "['../src/test.pl'],test,halt" -t 'halt(1)'
++ $(PCEBUILD) -q -g "['../src/test.pl'],test,halt" -t 'halt(1)'
+
+
+ ################################################################
+--- pl-5.6.4.orig/packages/xpce/src/test.pl 2005-11-03 04:10:22.000000000 +1300
++++ pl-5.6.4/packages/xpce/src/test.pl 2006-02-14 00:05:37.000000000 +1300
+@@ -35,6 +35,10 @@
+ ?- test.
+ - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - */
+
++:- asserta(library_directory('../prolog/lib')).
++:- use_module(library(pce)).
++:- use_module(library(pce_util)).
++
+ :- get(@pce, version, V),
+ format('XPCE/SWI-Prolog test suite. (XPCE version ~w)~n\
+ To run all tests run ?- test.~n~n', [V]).
+@@ -163,12 +167,12 @@
+ *******************************/
+
+ srcsink(contents-1) :-
+- numlist(32, 1000, L),
++ numlist(32, 255, L),
+ tmp_file(test, Tmp),
+- open(Tmp, write, Out, [encoding(utf8)]),
++ open(Tmp, write, Out, [encoding(iso_latin_1)]),
+ maplist(put_code(Out), L),
+ close(Out),
+- new(File, file(Tmp, utf8)),
++ new(File, file(Tmp, iso_latin_1)),
+ get(File, contents, String),
+ delete_file(Tmp),
+ get(String, value, Atom),
+@@ -193,7 +197,7 @@
+ *******************************/
+
+ foreign(Name) :-
+- atom_codes(Name, [1087, 1083, 1072, 1090, 1085, 1072, 1103]).
++ atom_codes(Name, [102, 105, 108, 101, 110, 97, 109, 101]).
+
+ file(env-1) :-
+ new(F, file('$PCEHOME/Defaults')),
+@@ -202,11 +206,6 @@
+ get(F, name, PceName),
+ same_file(PceName, PlName),
+ send(F, same, PlName).
+-file(home-1) :-
+- new(F, file('~/foobar')),
+- get(F, name, PceName),
+- expand_file_name('~/foobar', [PlName]),
+- same_file(PceName, PlName).
+ file(abs-1) :-
+ new(F, file(foobar)),
+ get(F, absolute_path, Abs),
+@@ -221,13 +220,15 @@
+ -> send(file(F), exists)
+ ; \+ send(file(F), exists)
+ )).
+-file(utf8-1) :-
++file(ascii-1) :-
+ foreign(Name),
+ new(F, file(Name)),
++ send(F, encoding, iso_latin_1),
+ send(F, open, write),
+ send(F, append, 'Hello world\n'),
+ send(F, close),
+ new(F2, file(Name)),
++ send(F2, encoding, iso_latin_1),
+ exists_file(Name),
+ send(F2, exists),
+ get(F2, contents, string('Hello world\n')),
+@@ -312,12 +313,12 @@
+ atom_concat(hello, Wide, New).
+ textbuffer(file-1) :-
+ new(TB, text_buffer),
+- numlist(32, 1000, L),
++ numlist(32, 255, L),
+ atom_codes(WAtom, L),
+ send(TB, append, WAtom),
+ tmp_file(test, Tmp),
+- send(TB, save, file(Tmp, utf8)),
+- get(file(Tmp, utf8), contents, string(Copy)),
++ send(TB, save, file(Tmp, iso_latin_1)),
++ get(file(Tmp, iso_latin_1), contents, string(Copy)),
+ delete_file(Tmp),
+ Copy == WAtom.
+ textbuffer(store-1) :-